Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Results 1 to 14 of 14
  1. #1
    Status
    Offline
    geonet_comp's Avatar
    Member Super Senior
    Join Date
    Aug 2007
    Posts
    527
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    [OOT] Mari sharing :)

    Sekedar mau sharing nih sekalian bantu dagangan seseorang di forum ini Click here to enlarge
    Tentang menggabungkan 2 koneksi untuk mendapatkan hasil yang optimal Click here to enlarge
    Alkisah...
    Saya kemaren mau nambah bw via vsat 2-way dan berhadapan dengan kendala bahwa koneksi vsat memiliki upstream yang cenderung tidak stabil tapi dengan download yang sangat stabil dengan kelebihan harga bandwidth murah. (2mbps downlink internasional only 7.5jt)
    Disatu sisi juga tersedia koneksi via astinet dengan bandwidth kecil tapi stabil baik up maupun down nya dengan catatan harga tinggi (128kbps 13jt!!!)sayang disini blom ada speedy kalo ada pasti bisa didayagunakan nih Click here to enlarge
    Bingung, kalo emang cuman mau pisahin trafik lokal sama internasional pasti gak enak karena up internasional dicekek dan tidak stabil,di loadbalancing pasti ancur, jadi si pedagang ini menyarankan gimana kalo trafik browsing via astinet dan download via vsat. Sempat saya coba tapi ternyata emang yang download gak sering2 amat pada peak time sehingga koneksi vsat cenderung kosong dan koneksi astinet overload, client pun bertambah dosanya karena sering menyebutkan isi kebun binatang Click here to enlarge .
    Akhirnya saya coba menerapkan ide si pedagang dengan menerapkan rule bahwa semua trafik yang berjenis html,php,dkk menggunakan astinet dan gambar maupun flash dan file2 jenis lainnya menggunakan vsat. Dan ternyata cukup ampuh karena sekarang bisa terjadi perimbangan antara keduanya dan ujung2nya client pun puas karena bisa ber-browsing ria dengan kecepatan teresterial dan mendownload ria dengan koneksi vsat, dan sebagai provider pun senang karena bisa mandapatkan harga murah dengan total bandwidth besar.. just waiting for speedy nih biar bisa neken harga lage Click here to enlarge

    Penerapan aplikasinya :
    -------------Proxy
    ---------------|
    VSAT---------MT---------Astinet
    ---------------|
    -------------Clients

    Proxy mengaplikasikan squid dengan pemafaatan tcp_outgoing_address dan acl urlpath_regex berfungsi sebagai transparent proxy
    MT untuk routing dan shaping
    VSAT dan Astinet as up provider
    Clients as him self Click here to enlarge

    Anyone any idea to share too, please ? Click here to enlarge

  2. The Following 2 Users Say Thank You to geonet_comp For This Useful Post:


  3. #2
    Status
    Offline
    [a]
    [a]'s Avatar
    Administrator
    Join Date
    Jun 2007
    Location
    Jakarta, Indonesia, Indonesia
    Posts
    1,729
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    1 (100%)
    nice sharing..

    any other idea, guys ?

  4. #3
    Status
    Offline
    rj-45's Avatar
    Moderator
    Join Date
    Jul 2007
    Posts
    885
    Reviews
    Read 0 Reviews
    Downloads
    1
    Uploads
    0
    Feedback Score
    0
    gw sering dapet teriakan2 isi kebun binatang Click here to enlarge apes dah kalo peak...yang kena pasti admin Hiks......

  5. #4
    Status
    Offline
    parot's Avatar
    Calon Member
    Join Date
    Jul 2007
    Posts
    98
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    @geonet_comp

    nah scriptnya publish jg dung hehehe Click here to enlarge

  6. #5
    Status
    Offline
    [a]
    [a]'s Avatar
    Administrator
    Join Date
    Jun 2007
    Location
    Jakarta, Indonesia, Indonesia
    Posts
    1,729
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    1 (100%)
    Click here to enlarge Originally Posted by parot Click here to enlarge
    @geonet_comp

    nah scriptnya publish jg dung hehehe Click here to enlarge
    ga usah dipaksa, bro...

    dah bagus bro geonet_comp mau share cerita dan idenya...

    tapi klo mau share config-nya lebih bagus lagi sih...Click here to enlarge

    klo ngga juga ga papa...kan itu hak nya...

  7. #6
    Status
    Offline
    geonet_comp's Avatar
    Member Super Senior
    Join Date
    Aug 2007
    Posts
    527
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by parot Click here to enlarge
    @geonet_comp

    nah scriptnya publish jg dung hehehe Click here to enlarge
    Click here to enlarge

    Skema :
    -------------Proxy
    ---------------|
    VSAT---------MT---------Astinet
    ---------------|
    -------------Clients

    Interface VSAT : 192.168.1.1/24
    Interface Astinet : 192.168.2.1/24
    Interface Proxy : 192.168.3.2/24 dan 192.168.3.3/24
    Interface Clients : 192.168.4.2/24
    Interface di MT :
    ke vsat : 192.168.1.2/24
    ke Astinet : 192.168.2.2/24
    ke Proxy : 192.168.3.1/24
    ke Clients : 192.168.4.1/24

    NAT :
    ;;proxy
    /ip firewall chain=srcnat src-addresses=192.168.3.2 out-interface=vsat action=src-nat to-addresses=192.168.1.1 to-ports=0-65535

    /ip firewall chain=srcnat src-addresses=192.168.3.3 out-interface=astinet action=src-nat to-addresses=192.168.2.1 to-ports=0-65535

    ;;clients
    /ip firewall chain=srcnat src-addresses=192.168.4.2 out-interface=vsat action=src-nat to-addresses=192.168.1.1 to-ports=0-65535

    ;;transparent proxy
    /ip firewall chain=dstnat protocol=tcp dst-port=80 in-interface=clients action=dst-nat to-addresses=192.168.3.2 to-ports=3128

    MANGLE:
    /ip firewall mangle chain=prerouting src-address=192.168.3.3 action=mark-connection new-connection-mark=browse passthrough=yes
    /ip firewall mangle chain=prerouting in-interface=proxy connection-mark=browse action=mark-routing new-routing-mark=browse

    ROUTING :
    /ip route add dst-address=0.0.0.0/0 gateway=192.168.1.1
    /ip route add dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=browse
    /ip route rule add src-address=192.168.3.3 action=lookup table=main

    Di MT dah selese untuk urusan NAT dan MANGLE serta ROUTING, lanjut di squid :

    edit /etc/squid.conf

    --------------------------------------------------------------------------------------------
    acl download urlpath_regex -i ftp \.exe$ \.mp3$ \.mp4$ \.tar.gz$ \.gz$ \.tar.bz2$ \.rpm$ \.zip$ \.rar$ \.avi$ \.mpg$ \.mpeg$
    acl download urlpath_regex -i \.rm$ \.iso$ \.wav$ \.mov$ \.dat$ \.mpe$ \.mid$ \.midi$ \.rmi$ \.wma$ \.wmv$ \.ogg$ \.ogm$ \.m
    acl download urlpath_regex -i \.mp2$ \.mpa$ \.wax$ \.m3u$ \.asx$ \.wpl$ \.wmx$ \.dvr-ms$ \.snd$ \.au$ \.aif$ \.asf$ \.m2v$ \
    acl download urlpath_regex -i \.ts$ \.tp$ \.trp$ \.div$ \.divx$ \.mod$ \.vob$ \.aob$ \.dts$ \.ac3$ \.cda$ \.vro$ \.deb$
    acl download urlpath_regex -i \.jpg$ \.png$ \.jpeg$ \.gif$ \.swf$

    tcp_outgoing_address 192.168.3.2 download
    tcp_outgoing_address 192.168.3.3

    server_persistent_connections off

    ---------------------------------------------------------------------------------------------

    That`s all bro, any another needed config please refer to your needed Click here to enlarge

  8. The Following 5 Users Say Thank You to geonet_comp For This Useful Post:


  9. #7
    Status
    Offline
    parot's Avatar
    Calon Member
    Join Date
    Jul 2007
    Posts
    98
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    geonet_comp Click here to enlargeClick here to enlarge

  10. #8
    Status
    Offline
    [a]
    [a]'s Avatar
    Administrator
    Join Date
    Jun 2007
    Location
    Jakarta, Indonesia, Indonesia
    Posts
    1,729
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    1 (100%)
    yahud emang nih bro satu ini...

  11. #9
    Status
    Offline
    c0nf's Avatar
    Contributor
    Join Date
    Jul 2007
    Location
    Bandung, Indonesia
    Posts
    1,816
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    mantapsClick here to enlarge

  12. #10
    Status
    Offline
    kunimihiro's Avatar
    Newbie
    Join Date
    Oct 2007
    Location
    Earth
    Posts
    66
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    kapaaan ya bs jago kyk om geonet Click here to enlarge

  13. #11
    Status
    Offline
    t3rm's Avatar
    Member Super Senior
    Join Date
    Aug 2007
    Posts
    665
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Ha ha ha ..
    Makanya kalau training, jangan buka yang lain ..

    Click here to enlarge

  14. #12
    Status
    Offline
    [a]
    [a]'s Avatar
    Administrator
    Join Date
    Jun 2007
    Location
    Jakarta, Indonesia, Indonesia
    Posts
    1,729
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    1 (100%)
    Click here to enlarge Originally Posted by t3rm Click here to enlarge
    Ha ha ha ..
    Makanya kalau training, jangan buka yang lain ..

    Click here to enlarge
    iya tuh...gara2 pas training dikasih akses internet, bukannya merhatiin malah buka2 site yg ga penting...heuheuhehehhehe....

    jadi nyesel krn sempet gitu jga Click here to enlarge

  15. #13
    Status
    Offline
    nana6262's Avatar
    Member
    Join Date
    Nov 2008
    Location
    Depan SMA I
    Posts
    174
    Reviews
    Read 0 Reviews
    Downloads
    1
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by geonet_comp Click here to enlarge
    Click here to enlarge

    Skema :
    -------------Proxy
    ---------------|
    VSAT---------MT---------Astinet
    ---------------|
    -------------Clients

    Interface VSAT : 192.168.1.1/24
    Interface Astinet : 192.168.2.1/24
    Interface Proxy : 192.168.3.2/24 dan 192.168.3.3/24
    Interface Clients : 192.168.4.2/24
    Interface di MT :
    ke vsat : 192.168.1.2/24
    ke Astinet : 192.168.2.2/24
    ke Proxy : 192.168.3.1/24
    ke Clients : 192.168.4.1/24

    NAT :
    ;;proxy
    /ip firewall chain=srcnat src-addresses=192.168.3.2 out-interface=vsat action=src-nat to-addresses=192.168.1.1 to-ports=0-65535

    /ip firewall chain=srcnat src-addresses=192.168.3.3 out-interface=astinet action=src-nat to-addresses=192.168.2.1 to-ports=0-65535

    ;;clients
    /ip firewall chain=srcnat src-addresses=192.168.4.2 out-interface=vsat action=src-nat to-addresses=192.168.1.1 to-ports=0-65535

    ;;transparent proxy
    /ip firewall chain=dstnat protocol=tcp dst-port=80 in-interface=clients action=dst-nat to-addresses=192.168.3.2 to-ports=3128

    MANGLE:
    /ip firewall mangle chain=prerouting src-address=192.168.3.3 action=mark-connection new-connection-mark=browse passthrough=yes
    /ip firewall mangle chain=prerouting in-interface=proxy connection-mark=browse action=mark-routing new-routing-mark=browse

    ROUTING :
    /ip route add dst-address=0.0.0.0/0 gateway=192.168.1.1
    /ip route add dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=browse
    /ip route rule add src-address=192.168.3.3 action=lookup table=main

    Di MT dah selese untuk urusan NAT dan MANGLE serta ROUTING, lanjut di squid :

    edit /etc/squid.conf

    --------------------------------------------------------------------------------------------
    acl download urlpath_regex -i ftp \.exe$ \.mp3$ \.mp4$ \.tar.gz$ \.gz$ \.tar.bz2$ \.rpm$ \.zip$ \.rar$ \.avi$ \.mpg$ \.mpeg$
    acl download urlpath_regex -i \.rm$ \.iso$ \.wav$ \.mov$ \.dat$ \.mpe$ \.mid$ \.midi$ \.rmi$ \.wma$ \.wmv$ \.ogg$ \.ogm$ \.m
    acl download urlpath_regex -i \.mp2$ \.mpa$ \.wax$ \.m3u$ \.asx$ \.wpl$ \.wmx$ \.dvr-ms$ \.snd$ \.au$ \.aif$ \.asf$ \.m2v$ \
    acl download urlpath_regex -i \.ts$ \.tp$ \.trp$ \.div$ \.divx$ \.mod$ \.vob$ \.aob$ \.dts$ \.ac3$ \.cda$ \.vro$ \.deb$
    acl download urlpath_regex -i \.jpg$ \.png$ \.jpeg$ \.gif$ \.swf$

    tcp_outgoing_address 192.168.3.2 download
    tcp_outgoing_address 192.168.3.3

    server_persistent_connections off

    ---------------------------------------------------------------------------------------------

    That`s all bro, any another needed config please refer to your needed Click here to enlarge

    mantep bos
    ini yang dicari-cari
    dah berhasil uji coba

    Tq

  16. #14
    Status
    Offline
    ndawir's Avatar
    Baru Gabung
    Join Date
    Aug 2008
    Posts
    5
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Mantab gans...tengkyu bagi2 ilmunya.:beer

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Mikrotik bisa untuk sharing IP Public ?
    By domba in forum Beginner Basics
    Replies: 67
    Last Post: 09-09-2014, 15:34
  2. Cara sharing file tapi beda subnetmask
    By Anoordy in forum General Networking
    Replies: 12
    Last Post: 31-01-2008, 22:54
  3. Sharing Pengalaman Warnet
    By b4yu in forum Beginner Basics
    Replies: 3
    Last Post: 10-12-2007, 19:51
  4. Replies: 1
    Last Post: 14-11-2007, 15:59

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •