Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Page 1 of 2 12 LastLast
Results 1 to 15 of 29
  1. #1
    Status
    Offline
    zdienos's Avatar
    Forum Guru
    Join Date
    Feb 2010
    Location
    ~/makasar
    Posts
    1,252
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    [solved] RouterOS sebagai bandwidth limiter (bridge mode)

    Salam buat para suhu...

    sebelumnya minta maaf kalo' salah tempat, n juga kalo' pertanyaannya rada-rada blo'on....

    pertanyaannya begini:
    * bagaimana cara membuat bandwidth limiter menggunan Mikrotik, tanpa bertindak sebagai gateway??
    * soalnya jaringannya sudah jadi, ga boleh diubah2 lagi


    untuk lebih bingungnya, nih gambar jaringan lokal saya:
    Click here to enlarge

    nah, saya maw buatin bandwidth limiter di antara gateway dan client (tanpa merubah konfigurasi client), seperti gambar:
    Click here to enlarge


    begitu ceritanya...
    kira2 bagaimana neh, settingan mikrotiknya??
    harus pake apa??
    newbie banget soalna.....

    trima kasih sebelumnya
    Last edited by zdienos; 24-04-2010 at 17:13. Reason: gambarnya salah :D

  2. #2
    Status
    Offline
    yosanpro's Avatar
    Co-Admin
    Join Date
    Nov 2007
    Location
    Bantul, Bantul, Yogyakarta
    Posts
    2,548
    Reviews
    Read 0 Reviews
    Downloads
    11
    Uploads
    4
    Feedback Score
    1 (100%)
    Sudahkah anda mencari di wiki?
    kalo belum coba lihat ... mungkin itu yang dimaksud?

    Prinsipnya sih, jadikan Mikrotik sebagai bridge, kemudian diset bridge menggunakan firewall,
    Code:
    / interface bridge settings
    set use-ip-firewall=yes
    kemudian set mangle untuk mark packet, kemudian bandwidth limit bisa diset melalui simple queue atau queue tree.
    Last edited by yosanpro; 12-03-2010 at 23:09.

  3. #3
    Status
    Offline
    zdienos's Avatar
    Forum Guru
    Join Date
    Feb 2010
    Location
    ~/makasar
    Posts
    1,252
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by yosanpro Click here to enlarge
    Sudahkah anda mencari di wiki?
    kalo belum coba lihat ... mungkin itu yang dimaksud?

    Prinsipnya sih, jadikan Mikrotik sebagai bridge, kemudian diset bridge menggunakan firewall,
    Code:
    / interface bridge settings
    set use-ip-firewall=yes
    kemudian set mangle untuk mark packet, kemudian bandwidth limit bisa diset melalui simple queue atau queue tree.

    ooo. yang itu..., sudah pernah ke situ sihh, tapi agak kurang hati2 bacanya, soalnya gambarnya kurang saya perhatikan... Click here to enlarge

    trima kasih om....
    ta' cobain dulu, kalo' ada masalah, minta tolong dibantu ya!!!!Click here to enlarge

  4. #4
    Status
    Offline
    zdienos's Avatar
    Forum Guru
    Join Date
    Feb 2010
    Location
    ~/makasar
    Posts
    1,252
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    @yosanpro

    tx, dah coba bridging dulu, nanti baru shaping bandwidthnya... Click here to enlarge


    1. kalo dari mesin mikrotik, ping ke
    -> gateway (172.16.15.254) :: bisa
    -> interface up (172.16.9.228) :: bisa
    -> interface dn (172.16.9.227) :: bisa
    2. tetapi kalo dari client (mis: 172.16.9.1), saya ping ke:
    -> interface up (172.16.9.228) :: bisa
    -> interface dn (172.16.9.227) :: bisa
    -> gateway (172.16.15.254) :: tidak bisa

    tolong dong, mungkin ada yang salah di konfigurasi nya...

    nih dia:


    Code:
    /interface ethernet
    set 0 arp=enabled auto-negotiation=yes cable-settings=default comment="" \
        disable-running-check=yes disabled=no full-duplex=yes mac-address=\
        00:03:FF:EA:E3:7C mtu=1500 name=internet speed=100Mbps
    set 1 arp=enabled auto-negotiation=yes cable-settings=default comment="" \
        disable-running-check=yes disabled=no full-duplex=yes mac-address=\
        00:03:FF:E9:E3:7C mtu=1500 name=lokal speed=100Mbps
    
    /interface bridge port
    add bridge=myBridge comment="" disabled=no edge=auto external-fdb=auto \
        horizon=none interface=internet path-cost=10 point-to-point=auto \
        priority=0x80
    add bridge=myBridge comment="" disabled=no edge=auto external-fdb=auto \
        horizon=none interface=lokal path-cost=10 point-to-point=auto priority=\
        0x80
    /interface bridge settings
    set use-ip-firewall=yes use-ip-firewall-for-pppoe=no \
        use-ip-firewall-for-vlan=no
    
    /ip address
    add address=172.16.9.228/21 broadcast=172.16.15.255 comment="" disabled=no \
        interface=up network=172.16.8.0
    add address=172.16.9.227/21 broadcast=172.16.15.255 comment="" disabled=no \
        interface=dn network=172.16.8.0
    
    /ip firewall mangle
    add action=mark-connection chain=prerouting comment="" disabled=no \
        dst-address=0.0.0.0/0 dst-port=80 new-connection-mark=http_conn passthrough=yes \
        protocol=tcp src-address=0.0.0.0/0
    add action=mark-packet chain=prerouting comment="" connection-mark=http_conn \
        disabled=no dst-address=0.0.0.0/0 new-packet-mark=http passthrough=no \
        protocol=tcp src-address=0.0.0.0/0
    
    /queue simple
    add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" \
        direction=both disabled=no dst-address=0.0.0.0/0 interface=all limit-at=\
        0/0 max-limit=256000/512000 name=main parent=none priority=8 queue=\
        default-small/default-small target-addresses=172.16.8.0/21 total-queue=\
        default-small

    Click here to enlarge

  5. #5
    Status
    Offline
    si_faisal's Avatar
    Contributor
    Join Date
    Jul 2008
    Location
    Jakarta & Sukabumi
    Posts
    485
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    mas

    itu yang dikasih ip brigde nya, cukup 1 saya

    jadi bukan ethernetnya, tapi interface brigde yang merupakan gabungan dari eth-up dan eth-down

    kemudian untuk marking packet, lakukan di chain forward

    HTH

  6. #6
    Status
    Offline
    Akangage's Avatar
    Administrator
    Join Date
    Aug 2007
    Location
    Daerah Khusus Ibukota Jakarta, Indonesia
    Posts
    4,195
    Reviews
    Read 0 Reviews
    Downloads
    210
    Uploads
    87
    Feedback Score
    0
    Click here to enlarge Originally Posted by si_faisal Click here to enlarge
    mas

    itu yang dikasih ip brigde nya, cukup 1 saya

    jadi bukan ethernetnya, tapi interface brigde yang merupakan gabungan dari eth-up dan eth-down

    kemudian untuk marking packet, lakukan di chain forward

    HTH
    WWWWWWOooooooouuuuuughhhhhhhhhhhhhhh~~~~~ SUHU & MASTER Linux Squid Indonesia angkat bicara MANTAB boz Click here to enlarge Click here to enlarge Click here to enlarge Click here to enlarge Click here to enlarge Click here to enlarge Click here to enlarge

  7. #7
    Status
    Offline
    si_faisal's Avatar
    Contributor
    Join Date
    Jul 2008
    Location
    Jakarta & Sukabumi
    Posts
    485
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    waduh Mimin Akang lagi ngimpi kali yee...
    saya nubitol Click here to enlarge

  8. #8
    Status
    Offline
    zdienos's Avatar
    Forum Guru
    Join Date
    Feb 2010
    Location
    ~/makasar
    Posts
    1,252
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by si_faisal Click here to enlarge
    mas

    itu yang dikasih ip brigde nya, cukup 1 saya

    jadi bukan ethernetnya, tapi interface brigde yang merupakan gabungan dari eth-up dan eth-down

    kemudian untuk marking packet, lakukan di chain forward

    HTH
    ooo gitu yaa...

    okelah kalo begitu, saya akan coba:
    1. ga usah kasih ip address untuk kedua ethernet, tapi cukup bridge nya aja
    2. lakukan chain forward

    trima kasih...

    ntar diposting lagi reportnya...

  9. #9
    Status
    Offline
    zdienos's Avatar
    Forum Guru
    Join Date
    Feb 2010
    Location
    ~/makasar
    Posts
    1,252
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by si_faisal Click here to enlarge
    mas

    itu yang dikasih ip brigde nya, cukup 1 saya

    jadi bukan ethernetnya, tapi interface brigde yang merupakan gabungan dari eth-up dan eth-down

    kemudian untuk marking packet, lakukan di chain forward

    HTH

    masih blum bisa tuh...
    saya reset ulang, kemudian saya set lagi sebagai berikut (seperti gambar):

    Click here to enlarge

    Code:
    /interface ethernet
    set 0 arp=enabled auto-negotiation=yes cable-settings=default comment="" \
        disable-running-check=yes disabled=no full-duplex=yes mac-address=\
        00:03:FF:EA:E3:7A mtu=1500 name=inet speed=100Mbps
    set 1 arp=enabled auto-negotiation=yes cable-settings=default comment="" \
        disable-running-check=yes disabled=no full-duplex=yes mac-address=\
        00:03:FF:E9:E3:7B mtu=1500 name=lan speed=100Mbps
    
    /interface bridge port
    add bridge=myBridge comment="" disabled=no edge=auto external-fdb=auto \
        horizon=none interface=inet path-cost=10 point-to-point=auto priority=\
        0x80
    add bridge=myBridge comment="" disabled=no edge=auto external-fdb=auto \
        horizon=none interface=lan path-cost=10 point-to-point=auto priority=0x80
    /interface bridge settings
    set use-ip-firewall=yes use-ip-firewall-for-pppoe=no \
        use-ip-firewall-for-vlan=no
    
    /ip address
    add address=172.16.9.230/21 broadcast=172.16.15.255 comment="" disabled=no \
        interface=myBridge network=172.16.8.0

    dari Mikrotik/Bridge (172.16.9.230) , saya coba ping ke:
    * client: 172.16.9.229 --> bisa
    * gateway: 172.16.15.254 -->bisa

    Click here to enlarge


    dari client/xp (172.16.9.229), saya coba ping ke:
    * mikrotik: 172.16.9.230 --> bisa
    * gateway: 172.16.15.254 --> tidak bisa

    Click here to enlarge



    kalo' semuanya dah bisa ping, baru deh saya limit (queue) ...., Click here to enlarge

    adakah yang salah sama settingan ku???

    tolonglah si newbie ini...

  10. #10
    Status
    Offline
    oktama's Avatar
    Forum Guru
    Join Date
    Jul 2008
    Location
    Jayapura
    Posts
    1,929
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    [QUOTE=zdienos;119562]masih blum bisa tuh...
    saya reset ulang, kemudian saya set lagi sebagai berikut (seperti gambar):

    Click here to enlarge

    Code:
    /interface ethernet
    set 0 arp=enabled auto-negotiation=yes cable-settings=default comment="" \
        disable-running-check=yes disabled=no full-duplex=yes mac-address=\
        00:03:FF:EA:E3:7A mtu=1500 name=inet speed=100Mbps
    set 1 arp=enabled auto-negotiation=yes cable-settings=default comment="" \
        disable-running-check=yes disabled=no full-duplex=yes mac-address=\
        00:03:FF:E9:E3:7B mtu=1500 name=lan speed=100Mbps
    
    /interface bridge port
    add bridge=myBridge comment="" disabled=no edge=auto external-fdb=auto \
        horizon=none interface=inet path-cost=10 point-to-point=auto priority=\
        0x80
    add bridge=myBridge comment="" disabled=no edge=auto external-fdb=auto \
        horizon=none interface=lan path-cost=10 point-to-point=auto priority=0x80
    /interface bridge settings
    set use-ip-firewall=yes use-ip-firewall-for-pppoe=no \
        use-ip-firewall-for-vlan=no
    
    /ip address
    add address=172.16.9.230/21 broadcast=172.16.15.255 comment="" disabled=no \
        interface=myBridge network=172.16.8.0

    dari Mikrotik/Bridge (172.16.9.230) , saya coba ping ke:
    * client: 172.16.9.229 --> bisa
    * gateway: 172.16.15.254 -->bisa

    Click here to enlarge


    dari client/xp (172.16.9.229), saya coba ping ke:
    * mikrotik: 172.16.9.230 --> bisa
    * gateway: 172.16.15.254 --> tidak bisa

    Click here to enlarge


    udah dimasukkan belom port2 dari mikrotiknya ke settingan bridge?
    assign salah satu port sebagai master dan port satunya sebagai slave, udah dilakukan blm?
    Last edited by oktama; 17-03-2010 at 17:23. Reason: baca lagi

  11. #11
    Status
    Offline
    zdienos's Avatar
    Forum Guru
    Join Date
    Feb 2010
    Location
    ~/makasar
    Posts
    1,252
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by oktama Click here to enlarge
    udah dimasukkan belom port2 dari mikrotiknya ke settingan bridge?
    assign salah satu port sebagai master dan port satunya sebagai slave, udah dilakukan blm?
    Code:
    /interface ethernet
    set 0 arp=enabled auto-negotiation=yes cable-settings=default comment="" \
        disable-running-check=yes disabled=no full-duplex=yes mac-address=\
        00:03:FF:EA:E3:7A mtu=1500 name=inet speed=100Mbps
    set 1 arp=enabled auto-negotiation=yes cable-settings=default comment="" \
        disable-running-check=yes disabled=no full-duplex=yes mac-address=\
        00:03:FF:E9:E3:7B mtu=1500 name=lan speed=100Mbps
    
    /interface bridge port
    add bridge=myBridge comment="" disabled=no edge=auto external-fdb=auto \
        horizon=none interface=inet path-cost=10 point-to-point=auto priority=\
        0x80
    add bridge=myBridge comment="" disabled=no edge=auto external-fdb=auto \
        horizon=none interface=lan path-cost=10 point-to-point=auto priority=0x80
    /interface bridge settings
    set use-ip-firewall=yes use-ip-firewall-for-pppoe=no \
        use-ip-firewall-for-vlan=no
    
    /ip address
    add address=172.16.9.230/21 broadcast=172.16.15.255 comment="" disabled=no \
        interface=myBridge network=172.16.8.0
    yang dibold itu ya om???, kalo bukan, gimana caranya??
    maklum masih newbiew Click here to enlarge

  12. #12
    Nuk3L1st
    Nuk3L1st's Avatar
    permasalahan yang sama mau membuat bw limiter, dengan mode bridge
    tapi masih bingung settingannya..
    ok ditunggu para master pencerahannya umtuk kami.

  13. #13
    Status
    Offline
    yosanpro's Avatar
    Co-Admin
    Join Date
    Nov 2007
    Location
    Bantul, Bantul, Yogyakarta
    Posts
    2,548
    Reviews
    Read 0 Reviews
    Downloads
    11
    Uploads
    4
    Feedback Score
    1 (100%)
    Setting subnet mask di client udah betul? aku kok curiga setting subnet mask di client masih 255.255.255.0 yah...

    Untuk setting di atas mustinya subnet masknya 255.255.248.0

  14. #14
    Status
    Offline
    zdienos's Avatar
    Forum Guru
    Join Date
    Feb 2010
    Location
    ~/makasar
    Posts
    1,252
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by yosanpro Click here to enlarge
    Setting subnet mask di client udah betul? aku kok curiga setting subnet mask di client masih 255.255.255.0 yah...

    Untuk setting di atas mustinya subnet masknya 255.255.248.0

    yahh om, tau lah dikit2 CIDR...
    /24 --> 255.255.255.0
    /21 --> 255.255.248.0

    ini bukan pemisalan, tapi kondisi real di kantor saya...
    Click here to enlarge

  15. #15
    Status
    Offline
    Ye_Nan_Thien's Avatar
    Forum Guru
    Join Date
    May 2008
    Posts
    1,731
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    3 (100%)
    [QUOTE=oktama;119609]
    Click here to enlarge Originally Posted by zdienos Click here to enlarge
    masih blum bisa tuh...
    saya reset ulang, kemudian saya set lagi sebagai berikut (seperti gambar):

    Click here to enlarge

    Code:
    /interface ethernet
    set 0 arp=enabled auto-negotiation=yes cable-settings=default comment="" \
        disable-running-check=yes disabled=no full-duplex=yes mac-address=\
        00:03:FF:EA:E3:7A mtu=1500 name=inet speed=100Mbps
    set 1 arp=enabled auto-negotiation=yes cable-settings=default comment="" \
        disable-running-check=yes disabled=no full-duplex=yes mac-address=\
        00:03:FF:E9:E3:7B mtu=1500 name=lan speed=100Mbps
    
    /interface bridge port
    add bridge=myBridge comment="" disabled=no edge=auto external-fdb=auto \
        horizon=none interface=inet path-cost=10 point-to-point=auto priority=\
        0x80
    add bridge=myBridge comment="" disabled=no edge=auto external-fdb=auto \
        horizon=none interface=lan path-cost=10 point-to-point=auto priority=0x80
    /interface bridge settings
    set use-ip-firewall=yes use-ip-firewall-for-pppoe=no \
        use-ip-firewall-for-vlan=no
    
    /ip address
    add address=172.16.9.230/21 broadcast=172.16.15.255 comment="" disabled=no \
        interface=myBridge network=172.16.8.0

    dari Mikrotik/Bridge (172.16.9.230) , saya coba ping ke:
    * client: 172.16.9.229 --> bisa
    * gateway: 172.16.15.254 -->bisa

    Click here to enlarge


    dari client/xp (172.16.9.229), saya coba ping ke:
    * mikrotik: 172.16.9.230 --> bisa
    * gateway: 172.16.15.254 --> tidak bisa

    Click here to enlarge


    udah dimasukkan belom port2 dari mikrotiknya ke settingan bridge?
    assign salah satu port sebagai master dan port satunya sebagai slave, udah dilakukan blm?
    si bos khan mau bikin sistem bridge jadi abaikan IP di Mikrotik yang di bridge, karena Ip bridge dimikrotik hanya digunakan untuk mangil mikrotik

    IP yang digunakan Client adalah ip dari Gateway dalam kasus ini 172.16.15.254/21 dan gatewaynya ke 172.16.15.254

    ini topologi Simplenya

    Router (192.168.1.1/24)
    :
    Limiter (192.168.1.254/24)
    :
    Client (192.168.1.2-192.168.253)
    Gatewaynya ke 192.168.1.1
    Last edited by Ye_Nan_Thien; 21-03-2010 at 10:39.

 

 
Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. BILLING pakai VMWare(mikocok) sebagai limiter
    By t1kuZz in forum General Networking
    Replies: 7
    Last Post: 02-10-2012, 11:51
  2. Replies: 24
    Last Post: 27-09-2010, 15:21
  3. Jual Bandwidth murah,tapi bukan Murahan...
    By Sinyo in forum ISP / Network Link
    Replies: 42
    Last Post: 01-10-2009, 22:40
  4. Mikrotik sebagai LIMITER
    By key cenk in forum General Networking
    Replies: 11
    Last Post: 04-05-2009, 12:52
  5. <ask> bandwidth limiter, proxy dan security
    By Viceroy in forum General Networking
    Replies: 6
    Last Post: 05-02-2009, 12:37

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •