Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Results 1 to 3 of 3
  1. #1
    Status
    Offline
    xeon's Avatar
    Verified Account - Partner
    Join Date
    Mar 2008
    Location
    DKI Jakarta
    Posts
    1,537
    Reviews
    Read 0 Reviews
    Downloads
    3
    Uploads
    0
    Feedback Score
    2 (100%)

    Auto Update OpenIXP Address List

    Bagi yang membutuhkan list address OpenIXP, berikut adalah scriptnya:

    Code:
    :if ([:len [/file find name=openixp.rsc]] > 0) do={/file remove openixp.rsc }; /tool fetch mode=http address=www.dcsindo.com host=www.dcsindo.com src-path=/contrib/openixp.rsc;/import openixp.rsc


    Jika ingin dibuat otomatis, maka dapat dimasukkan ke dalam scheduler dengan cara:

    Code:
    /system scheduler add disabled=no interval=1d name=update-openixp on-event=":if ([:len [/file find name=openixp.rsc]] > 0) do={/file remove openixp.rsc }; /tool fetch mode=http address=www.dcsindo.com host=www.dcsindo.com src-path=/contrib/openixp.rsc;/import openixp.rsc" policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api start-time=04:00:00
    Script ini akan membuat auto update dengan durasi 1 hari, pada jam 4.00



    ==================================================
    DIGITAL CIPTA SOLUSINDO
    Authorized Distributor
    Phone : +6221 6511115. Fax. : +6221 6400115.
    Website :

    Click here to enlarge Click here to enlarge Click here to enlarge Click here to enlarge
    Last edited by xeon; 25-08-2011 at 16:05.

  2. #2
    Status
    Offline
    ucok_karnadi's Avatar
    ..:: Masih Bodoh ::..
    Join Date
    Jan 2009
    Location
    PATI - JAWA TENGAH
    Posts
    1,178
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    sebarapa banyak perbedaan dengan nice yg ada di mikrotik.co.id?

    ---------- Post added at 11:15 ---------- Previous post was at 09:56 ----------

    Click here to enlarge Originally Posted by xeon Click here to enlarge
    Bagi yang membutuhkan list address OpenIXP, berikut adalah scriptnya:

    Code:
    :if ([:len [/file find name=openixp.rsc]] > 0) do={/file remove openixp.rsc }; /tool fetch mode=http address=www.dcsindo.com host=www.dcsindo.com src-path=/contrib/openixp.rsc;/import openixp.rsc


    Jika ingin dibuat otomatis, maka dapat dimasukkan ke dalam scheduler dengan cara:

    Code:
    /system scheduler add disabled=no interval=1d name=update-openixp on-event=":if ([:len [/file find name=openixp.rsc]] > 0) do={/file remove openixp.rsc }; /tool fetch mode=http address=www.dcsindo.com host=www.dcsindo.com src-path=/contrib/openixp.rsc;/import openixp.rsc" policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api start-time=04:00:00
    Script ini akan membuat auto update dengan durasi 1 hari, pada jam 4.00
    mohon maaf untuk TS. untuk segmen ip yg di buat address list banyak yg tumpang tindih.

    sebuah contoh :

    Code:
    add list=openixp address="14.102.152.0/22"
    add list=openixp address="14.102.152.0/24"
    add list=openixp address="14.102.153.0/24"
    add list=openixp address="14.102.154.0/24"
    add list=openixp address="14.102.155.0/24"
    add list=openixp address="27.50.16.0/20"
    add list=openixp address="27.50.16.0/24"
    add list=openixp address="27.50.17.0/24"
    add list=openixp address="27.50.18.0/24"
    add list=openixp address="27.50.19.0/24"
    add list=openixp address="27.50.20.0/24"
    add list=openixp address="27.50.21.0/24"
    add list=openixp address="27.50.22.0/24"
    add list=openixp address="27.50.23.0/24"
    add list=openixp address="27.50.24.0/24"
    add list=openixp address="27.50.25.0/24"
    add list=openixp address="27.50.26.0/24"
    add list=openixp address="27.50.27.0/24"
    add list=openixp address="27.50.28.0/24"
    add list=openixp address="27.50.29.0/24"
    add list=openixp address="27.50.30.0/24"
    add list=openixp address="27.50.31.0/24"

    kenapa tidak dibuat saja seperti berikut

    Code:
    add list=openixp address="14.102.152.0/22"
    add list=openixp address="27.50.16.0/20"
    toh ip yg saya buang tersebut sudah masuk ke address diatasnya
    ___________________________________________


  3. #3
    Status
    Offline
    xeon's Avatar
    Verified Account - Partner
    Join Date
    Mar 2008
    Location
    DKI Jakarta
    Posts
    1,537
    Reviews
    Read 0 Reviews
    Downloads
    3
    Uploads
    0
    Feedback Score
    2 (100%)
    Click here to enlarge Originally Posted by ucok_karnadi Click here to enlarge
    sebarapa banyak perbedaan dengan nice yg ada di mikrotik.co.id?

    ---------- Post added at 11:15 ---------- Previous post was at 09:56 ----------



    mohon maaf untuk TS. untuk segmen ip yg di buat address list banyak yg tumpang tindih.

    sebuah contoh :

    Code:
    add list=openixp address="14.102.152.0/22"
    add list=openixp address="14.102.152.0/24"
    add list=openixp address="14.102.153.0/24"
    add list=openixp address="14.102.154.0/24"
    add list=openixp address="14.102.155.0/24"
    add list=openixp address="27.50.16.0/20"
    add list=openixp address="27.50.16.0/24"
    add list=openixp address="27.50.17.0/24"
    add list=openixp address="27.50.18.0/24"
    add list=openixp address="27.50.19.0/24"
    add list=openixp address="27.50.20.0/24"
    add list=openixp address="27.50.21.0/24"
    add list=openixp address="27.50.22.0/24"
    add list=openixp address="27.50.23.0/24"
    add list=openixp address="27.50.24.0/24"
    add list=openixp address="27.50.25.0/24"
    add list=openixp address="27.50.26.0/24"
    add list=openixp address="27.50.27.0/24"
    add list=openixp address="27.50.28.0/24"
    add list=openixp address="27.50.29.0/24"
    add list=openixp address="27.50.30.0/24"
    add list=openixp address="27.50.31.0/24"

    kenapa tidak dibuat saja seperti berikut

    Code:
    add list=openixp address="14.102.152.0/22"
    add list=openixp address="27.50.16.0/20"
    toh ip yg saya buang tersebut sudah masuk ke address diatasnya
    Memang inilah perbedaannya dengan yang list yang dari citraweb.

    Kami memberikan seluruh list yang masuk ke dalam daftar OpenIXP, tanpa edit sama sekali.

    Hal ini memudahkan untuk melakukan perbandingan bagi yang melakukan BGP dan menggunakan list, karena jumlahnya pasti sama. Begitu terlihat ada jumlah yang tidak sama, maka dipastikan ada IP yang kurang.

    Bisa merupakan kelebihan, dan juga bisa merupakan kekurangan. Tetapi dengan melakukan hal ini, kami harap dapat memberikan alternative bagi rekan rekan semua.

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [How-to] Auto Update Address-List IIX di Router Mikrotik
    By tajid.yakub in forum QOS & Traffic Shaping
    Replies: 24
    Last Post: 06-03-2013, 15:45
  2. Auto-Update DynDNS IP
    By psycronicx in forum Scripting @ Mikrotik
    Replies: 11
    Last Post: 27-03-2012, 18:50
  3. [SHARE] The true OPENIXP address list
    By xeon in forum General Networking
    Replies: 20
    Last Post: 10-11-2011, 18:02
  4. The true OPENIXP address list
    By xeon in forum Tutorial
    Replies: 6
    Last Post: 03-06-2011, 18:43
  5. Replies: 12
    Last Post: 11-04-2008, 08:28

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •