Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Results 1 to 2 of 2
  1. #1
    Status
    Offline
    aldix55's Avatar
    Baru Gabung
    Join Date
    Aug 2017
    Location
    Jakarta
    Posts
    9
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    Saran settingan apa yang kurang.

    Permisi suhu-suhu dan master-master.
    Saya newbie banget nih pakai mikrotik, saya mau minta saran dan masukan dari master-master mengenai settingan apa yang kurang agar mikrotik saya lebih optimal.
    Sekalian saya share juga config saya, mungkin akan berguna untuk yang lain.

    ISP : First Media Upto 20Mbps
    Fungsi jaringan : pemakaian pribadi atau untuk dirumah, seperti browsing,streaming dan online gaming.
    Pemakai tetap ada 11 user terdiri dari 3 laptop, 2 PC, 6 Smartphone, saya daftarkan macnya di IP ARP dan DHCP Server Lease menjadi static.
    DHCP saya buat hingga IP 40 karena terkadang teman saya dan teman adik saya suka datang bergerombol.

    Topologi:

    Modem Wifi FM Docsis 3.0 ----- Mikrotik RB 433 tanpa antena ----- Linksys wrt-54gl (ddwrt)

    Fitur Router.
    Docsis 3.0 : Fitur wifi, SPI Firewall dan dhcp saya matikan, IP docsis 3.0 : 192.168.0.1
    Linksys : Fitur SPI Firewall dan wan saya matikan, fitur Wifi saya aktifkan, dan menggunakan DHCP forwarder ke ip 192.168.100.1 agar dhcp diatur di mikrotik, IP linksys : 192.168.100.2

    Settingan ini saya tidak pakai dhcp client, prosesnya terjadi di modem docsis 3.0.
    sebelumnya saat masih docsis 2.0 tanpa wifi, saya pakai dhcp client.

    Setting standar

    Setting ip address
    Code:
    /ip address
    add address=192.168.0.2/24 interface=FirstMedia network=192.168.0.0
    add address=192.168.100.1/26 interface=LAN network=192.168.100.0
    Setting ip route
    Code:
    /ip route
    add distance=1 gateway=192.168.0.1
    Setting masqurade
    Code:
    /ip firewall nat
    add action=masquerade chain=srcnat comment="First Media" out-interface=FirstMedia
    Setting Pool
    Code:
    /ip pool
    add name=LAN-dhcp-pool ranges=192.168.100.4-192.168.100.40
    Setting DHCP Server
    Code:
    /ip dhcp-server
    add address-pool=LAN-dhcp-pool disabled=no interface=LAN lease-time=3d name=Lan-DHCP
    /ip dhcp-server network
    add address=192.168.100.0/26 gateway=192.168.100.1
    Setting DNS
    Code:
    /ip dns
    set allow-remote-requests=yes cache-size=5120KiB max-udp-packet-size=512 servers=209.244.0.3,209.244.0.4
    /ip dns static
    add address=209.244.0.3 name="provider lv 31 - Primary"
    add address=209.244.0.4 name="provider lv 31 - secondary"
    Settingan Tambahan

    Setting Redirect DNS
    Code:
    /ip firewall nat
    add action=redirect chain=dstnat comment="Redirect DNS" dst-port=53 protocol=tcp to-ports=53
    add action=redirect chain=dstnat dst-port=53 protocol=udp to-ports=53
    Settingan Firewall agan adhielesmana di
    Code:
    /ip firewall filter
    add chain=forward comment="Allow semua akses internet to client" dst-address=192.168.100.0/26 in-interface=FirstMedia out-interface=LAN
    add chain=input comment="Allow Remote winbox dari Publik" dst-port=8291 in-interface=FirstMedia protocol=tcp
    add chain=input comment="Allow NTP Traffic" in-interface=FirstMedia protocol=udp src-port=123
    add chain=input comment="Allow DNS Traffic" in-interface=FirstMedia protocol=udp src-port=53
    add chain=input comment="Allow INTERNAL WEB PROXY Traffic" in-interface=FirstMedia protocol=tcp src-port=80
    add chain=input comment="Allow Ping Traceroute Traffic" in-interface=FirstMedia protocol=icmp
    add chain=input comment=CloudIP in-interface=FirstMedia protocol=udp src-port=15252
    add action=add-src-to-address-list address-list=spam address-list-timeout=30m chain=input comment="Log Ip Yang Di Tolak" connection-state=new in-interface=FirstMedia
    add action=drop chain=input comment="Drop Semua Akses yang tidak di ijinkan" in-interface=FirstMedia src-address-list=spam
    Settingan Firewall agan okto_2005 di
    Code:
    /ip firewall filter
    add action=add-src-to-address-list address-list="port scanners" address-list-timeout=2w chain=input comment="Port scanners to list " protocol=tcp psd=21,3s,3,1
    add action=add-src-to-address-list address-list="port scanners" address-list-timeout=2w chain=input comment="NMAP FIN Stealth scan" protocol=tcp tcp-flags=fin,!syn,!rst,!psh,!ack,!urg
    add action=add-src-to-address-list address-list="port scanners" address-list-timeout=2w chain=input comment="SYN/FIN scan" protocol=tcp tcp-flags=fin,syn
    add action=add-src-to-address-list address-list="port scanners" address-list-timeout=2w chain=input comment="SYN/RST scan" protocol=tcp tcp-flags=syn,rst
    add action=add-src-to-address-list address-list="port scanners" address-list-timeout=2w chain=input comment="FIN/PSH/URG scan" protocol=tcp tcp-flags=fin,psh,urg,!syn,!rst,!ack
    add action=add-src-to-address-list address-list="port scanners" address-list-timeout=2w chain=input comment="ALL/ALL scan" protocol=tcp tcp-flags=fin,syn,rst,psh,ack,urg
    add action=add-src-to-address-list address-list="port scanners" address-list-timeout=2w chain=input comment="NMAP NULL scan" protocol=tcp tcp-flags=!fin,!syn,!rst,!psh,!ack,!urg
    add action=drop chain=input comment="dropping port scanners" src-address-list="port scanners"

    Settingan Queue Tree agan oktama di
    -Firewall
    Code:
    /ip firewall mangle
    add action=mark-packet chain=prerouting comment="PROXY HIT LOSS" dscp=12 new-packet-mark=PROXY-HIT passthrough=no
    add action=mark-connection chain=prerouting comment="Marking connection setiap pc-client" new-connection-mark=pc01 src-address=192.168.100.4
    add action=mark-connection chain=prerouting new-connection-mark=pc02 src-address=192.168.100.5
    add action=mark-connection chain=prerouting new-connection-mark=pc03 src-address=192.168.100.6
    ----------Dst sampai pc37
    
    /ip firewall mangle
    add action=mark-packet chain=prerouting comment="Marking packet dari setiap connection yang terjadi" connection-mark=pc01 new-packet-mark=pc01 passthrough=no
    add action=mark-packet chain=prerouting connection-mark=pc02 new-packet-mark=pc02 passthrough=no
    add action=mark-packet chain=prerouting connection-mark=pc03 new-packet-mark=pc02 passthrough=no
    ----------Dst sampai pc37
    -Queue Tree
    Code:
    /queue type
    add kind=pcq name=PCQ-DMbps pcq-classifier=dst-address pcq-rate=20M
    add kind=pcq name=PCQ-UMbps pcq-classifier=src-address pcq-rate=3M
    
    /queue tree
    add name=PROXY-HIT packet-mark=PROXY-HIT parent=LAN
    add max-limit=20M name=Downlink parent=LAN
    
    add limit-at=128k max-limit=20M name="down-pc01(100.4)" packet-mark=pc01 parent=Downlink queue=PCQ-DMbps
    add limit-at=128k max-limit=20M name="down-pc02(100.5)" packet-mark=pc02 parent=Downlink queue=PCQ-DMbps
    add limit-at=128k max-limit=20M name="down-pc03(100.6)" packet-mark=pc03 parent=Downlink queue=PCQ-DMbps
    -----------Dst sampai ip 100.40
    
    /queue tree
    add max-limit=3M name=Uplink parent=FirstMedia
    add limit-at=64k max-limit=3M name="up-pc01(100.4)" packet-mark=pc01 parent=Uplink queue=PCQ-UMbps
    add limit-at=64k max-limit=3M name="up-pc02(100.5)Aldix-HP" packet-mark=pc02 parent=Uplink queue=PCQ-UMbps
    add limit-at=64k max-limit=3M name="up-pc03(100.6)" packet-mark=pc03 parent=Uplink queue=PCQ-UMbps
    -----------Dst sampai ip 100.40
    Hasil :
    Work 100%

    Pertanyaannya :
    -apakah ada yang kurang atau salah dengan settingan saya, suapaya lebih maknyus.
    -apakah ada masukan atau saran,yang perlu saya tambah lagi agar lebih maksimal.
    -apakah settingan quee treenya bisa di gabung dengan pemisahan trafik IX dan IIX, di thread atau
    - semua modem diletakan di lantai 2, saya pernah mencoba menggunakan range extender huawei WS331c di lantai 1 tapi entah kenapa perangkat di lantai 1 tidak dapat terkoneksi ke internet, dan mac yang diterima dari repeater tersebut berubah tidak sesuai dengan mac address perangkat" di lantai 1 yang sudah saya masukan ke list ARP.
    - ada saran untuk penggunaan proxy harus pakai apa dan perangkat apa? jika memakai web proxy internal, kendalanya memori di rb sangat minim dan tidak ada slot tambahan micro sd maupun usb. atau master2 ada saran modifikasi rb 433 agar ada slot usb atau microsd, dengan cara oprek daleman atau menggunakan minipci atau rj45 to usb converter. Yang penting bisa hemat listrik tanpa pakai pc yg sedot pulsa listrik?
    - dan ada masalah di winbox, saat muncul notifikasi dengan pilihan "yes" dan "no", pillihan tersebut tidak bisa di klik maupun di tekan enter.
    winbox V6.33 on RB433 (mipsbe) License lv 4.


    Mohon pencerahannya para master-master dan suhu-suhu.

    Terima Kasih. Click here to enlarge Click here to enlarge
    Last edited by aldix55; 30-08-2017 at 20:31.

  2. #2
    Status
    Offline
    yosanpro's Avatar
    Co-Admin
    Join Date
    Nov 2007
    Location
    Bantul, Bantul, Yogyakarta
    Posts
    2,562
    Reviews
    Read 0 Reviews
    Downloads
    11
    Uploads
    4
    Feedback Score
    1 (100%)
    -apakah ada yang kurang atau salah dengan settingan saya, suapaya lebih maknyus.
    Saya kira tidak ada masalah serius pada settingan agan, cuman untuk setting firewall gan okto_2005 sebetulnya tidak perlu (redundant dan tidak akan dijalankan) kalau sudah pakai setting firewall gan adhielesmana di atasnya.

    O ya, untuk setting queue yang ini:
    Code:
    /queue type
    add kind=pcq name=PCQ-DMbps pcq-classifier=dst-address pcq-rate=20M
    add kind=pcq name=PCQ-UMbps pcq-classifier=src-address pcq-rate=3M
    artinya masing-masing perangkat yang terhubung akan mendapat pembatasan upload 3mbps dan download 20mbps (sama dengan max-limit). Saran saya sih jangan mengalokasikan maksimum bandwidth ke tiap perangkat, cuman kalo agan ngerti konsekuensinya ya monggo.
    -apakah settingan quee treenya bisa di gabung dengan pemisahan trafik IX dan IIX, di thread Step by step memprioritaskan trafic Game Online IIX atau Memisahkan IIX & Internasional menggunakan QUEUE TREE
    Untuk yang ini sebetulnya bukan tak mungkin, tetapi cukup sulit dilakukan, tidak sekedar copy-paste rule-rule yang bersangkutan tetapi juga harus menggunakan logika. Ingat, tiap packet pada suatu chain hanya bisa mempunyai 1 packet marking yang diproses di queue, dan penambahan marking pada packet yang sudah di-marking hanya akan re-assign packet marking ke marking yang baru.
    - semua modem diletakan di lantai 2, saya pernah mencoba menggunakan range extender huawei WS331c di lantai 1 tapi entah kenapa perangkat di lantai 1 tidak dapat terkoneksi ke internet, dan mac yang diterima dari repeater tersebut berubah tidak sesuai dengan mac address perangkat" di lantai 1 yang sudah saya masukan ke list ARP.
    Saya belum pernah pakai perangkat yang disebutkan, tetapi kalau setting repeater perangkat menggunakan "Universal Repeater" atau sejenisnya, maka mac-address perangkat yang terkoneksi ke repeater tidak akan bisa dideteksi. Solusinya bisa menggunakan repeater wds (dengan catatan AP juga mendukung wds).
    - ada saran untuk penggunaan proxy harus pakai apa dan perangkat apa? jika memakai web proxy internal, kendalanya memori di rb sangat minim dan tidak ada slot tambahan micro sd maupun usb. atau master2 ada saran modifikasi rb 433 agar ada slot usb atau microsd, dengan cara oprek daleman atau menggunakan minipci atau rj45 to usb converter. Yang penting bisa hemat listrik tanpa pakai pc yg sedot pulsa listrik?
    Untuk saya pribadi sih untuk saat ini mending ga usah pakai proxy, kecuali agan punya PC spec sultan. Proxy pada perangkat yang minim resource (CPU, memory, perangkat penyimpan dengan iops tinggi) hanya akan menjadi bottleneck bikin lambat jaringan, ditambah lagi kebanyakan situs saat ini udah dynamic content sehingga kemungkinan akan banyak cache_miss (kecuali dengan setting proxy khusus dynamic content, yang mana harus rajin update settingan).
    - dan ada masalah di winbox, saat muncul notifikasi dengan pilihan "yes" dan "no", pillihan tersebut tidak bisa di klik maupun di tekan enter.
    winbox V6.33 on RB433 (mipsbe) License lv 4.
    Saya sendiri belum pernah menemui kasus tersebut, coba upgrade atau downgrade ke versi lain dan lihat apakah masih ada masalah tersebut.
    A person's junk is another person's treasure.

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [ASK] [ ask ] saran squid yang bagus ?
    By ndra.boyz in forum General Networking
    Replies: 7
    Last Post: 07-02-2015, 14:44
  2. [ASK] Settingan yang tepat dari topology yang ada ?
    By aaputha in forum General Networking
    Replies: 9
    Last Post: 17-09-2013, 18:36
  3. [ASK] Fitur routeros v3.30 yang kurang optimal
    By candraarris in forum Wireless Networking
    Replies: 2
    Last Post: 26-01-2012, 22:43
  4. Replies: 4
    Last Post: 06-12-2010, 12:31
  5. Settingan ini ada yang salah gak ya,
    By azteric in forum Scripting @ Mikrotik
    Replies: 9
    Last Post: 18-02-2010, 21:19

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •