Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Results 1 to 6 of 6
  1. #1
    Status
    Offline
    Anto.PJ's Avatar
    Forum Guru
    Join Date
    May 2011
    Location
    macz
    Posts
    1,697
    Reviews
    Read 0 Reviews
    Downloads
    7
    Uploads
    0
    Feedback Score
    0

    [SHARE] distribusi IP publik via PPTP (BCP-Bridge Ethernet dan PPTP server)

    pagi ini ane meremote router. trus dirouter menggunakan IP publik CIDR /25
    nah, ip publik tersebut pengen didistirbusikan via pptp (router as pptp server)
    bagaimana caranya? kita gunakan BCP, based from

    IP public = 123.45.67.128/25, GW 123.45.67.254
    to the point.
    1. add bridge
    Code:
    /interface bridge add name=Public protocol-mode=rstp
    2. add interface ethernet yang mengarah ke WAN sebagai port Bridge
    Code:
    /interface bridge port add interface=eth1 bridge=Public
    3. add IP ke bridge "Public"
    Code:
    /ip address add address=123.45.67.129/25 interface=Public
    4. add sebagai default route
    Code:
    /ip route add dst-address=0.0.0.0/0 gateway=123.45.67.254
    so, router udah bisa internetan Click here to enlarge
    Code:
    admin@MikroTik > ip route pr  
    Flags: X - disabled, A - active, D - dynamic, 
    C - connect, S - static
     #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
     0 A S  0.0.0.0/0                          123.45.67.254          1
     3 ADC  123.45.67.128/25   123.45.67.129   Public                 0
     4 ADC  172.16.1.0/30      172.16.1.1      ether4                 0
     5 ADC  192.168.42.0/24    192.168.42.127  ether3                 0
    5. enable pptp server
    Code:
    /interface pptp-server server set enabled=yes
    6. set profile pptp
    nah.. sebelum create pastikan IP pool diset
    ip yang telah terpakai adalah 123.45.67.129 dan 123.45.67.254 maka ip yang tersedia x.130- x.253
    Code:
    /ip pool add name=pptp-public ranges=123.45.67.130-123.45.67.253
    gunakan di profile
    Code:
    /ppp profile add name=myclient bridge=Public remote-address=pptp-public local-address=123.45.67.129
    perlu diperhatikan, kita menggunakan local address yang sama dengan ip di interface public.

    7. so, create client-secret
    Code:
    /ppp secret add name=user1 password=12345 profile=myclient service=pptp

    its ok, sekarang pindah ke router client
    1. create pptp client di router client
    Code:
    client@MikroTik > /interface pptp-client add user=user1 password=12345 profile=default connect-to=123.45.67.129
    dan running
    Code:
    client@MikroTik > interface pptp-client pr  
    Flags: X - disabled, R - running 
     0  R name="pptp-out1" max-mtu=1460 max-mru=1460 mrru=disabled 
          connect-to=123.45.67.129 user="user1" password="12345" 
          profile=default-encryption add-default-route=no dial-on-demand=no 
          allow=pap,chap,mschap1,mschap2
    nah.. di router pptp server akan muncul IP dynamic kaya gini
    Code:
    admin@MikroTik >/ip address print
    11    123.45.67.129/25    123.45.67.128    Public
    12 D 123.45.67.129/32    123.45.67.150    <pptp-user1>
    itu gpp.. ip publik sekarang berada di client..
    nah.. permasalahannya muncul.. klien tidak bisa konek ke internet via pptp (jika dijadikan sebagai default route)

    ternyata masalahnya di MAC-Address.. dan ini berkaitan dengan ARP
    so interface bridge=Public kita set sebagai proxy ARP

    Code:
    admin@MikroTik >/interface bridge set Public arp=proxy-arp
    Code:
    interface bridge print
    Flags: X - disabled, R - running 
     0  R name="Public" mtu=1500 l2mtu=65535 arp=proxy-arp 
          mac-address=00:00:00:00:00:00 protocol-mode=rstp priority=0x8000 
          auto-mac=yes admin-mac=00:00:00:00:00:00 max-message-age=20s 
          forward-delay=15s transmit-hold-count=6 ageing-time=5m
    dan router client pun udah bisa diremote dari public.. (kalo pool dirubah ke static)
    udah.. gitu aja.
    Last edited by Anto.PJ; 05-01-2015 at 10:02.

  2. The Following 5 Users Say Thank You to Anto.PJ For This Useful Post:


  3. #2
    Status
    Offline
    yoyoxcomputer's Avatar
    Newbie
    Join Date
    Nov 2009
    Posts
    29
    Reviews
    Read 0 Reviews
    Downloads
    1
    Uploads
    0
    Feedback Score
    0
    Muanteb tenan...
    nanti ngoprek bareng lagi yach..

    teknik BCP kelar...

    next distribusi ip dengan teknik OSPF Click here to enlarge

  4. #3
    Status
    Offline
    si_faisal's Avatar
    Contributor
    Join Date
    Jul 2008
    Location
    Jakarta & Sukabumi
    Posts
    486
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    ngeri2 sedap ini Click here to enlarge

    thanks for sharing
    Training MikroTik - jagonetwork.id

  5. #4
    Status
    Offline
    marsando's Avatar
    Baru Gabung
    Join Date
    Apr 2009
    Posts
    19
    Reviews
    Read 0 Reviews
    Downloads
    3
    Uploads
    0
    Feedback Score
    0
    wah mangtab..... matur suwun kang bertambah lg pengetahuan ku.... nanti tak coba praktekkan

  6. #5
    Status
    Offline
    tendabiru's Avatar
    Newbie
    Join Date
    Jul 2009
    Location
    Indonesia
    Posts
    20
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Selamat siang Pak Anto,

    Saya mencoba tutorial diatas beberapa kali belum berhasil juga.
    Apakah boleh minta tolong dengan screenshoot per panel yang di setting ?
    Bingung juga kenapa tidak juga berhasil setiap kali setting disisi client yang di luar kota.

    Terima kasih

  7. #6
    Status
    Offline
    ronnypras's Avatar
    Baru Gabung
    Join Date
    Dec 2009
    Posts
    6
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Bang...kalo client pakek windows gimana ya??
    Kok pas cek ip public , ga dapet ip public ya??dapetnya ip punlic router pusat.Bukan ip publicnya pptp windows.Terus ip publicnya di windows , di ping dari public lain , gak mau replay

    Thanx...

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Membuat VPN Server PPtP Mikrotik
    By adil_stelk10 in forum General Networking
    Replies: 65
    Last Post: 29-12-2011, 16:53
  2. Req : PPTP gak bisa konek (pptp need gre)
    By w1z4rd in forum General Networking
    Replies: 26
    Last Post: 10-11-2011, 19:20
  3. Seting PPTP Server
    By sukhoi37 in forum Tutorial
    Replies: 17
    Last Post: 09-12-2010, 20:21
  4. VPN Server menggunakan PPtP
    By abdillah in forum General Networking
    Replies: 4
    Last Post: 03-12-2009, 02:34
  5. PPTP Client Dan PPTP Server Di Mikrotik
    By buluxs in forum Beginner Basics
    Replies: 12
    Last Post: 19-08-2009, 13:15

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •