Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Results 1 to 3 of 3
  1. #1
    Status
    Offline
    borokovic's Avatar
    Newbie
    Join Date
    Oct 2009
    Location
    Aceh Singkil
    Posts
    55
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    Otomatis mengganti login page dengan Netwatch

    Saya punya hotspot berbeda lokasi dengan server saya, terkadang koneksi dari BTS ke server terputus, atau bahkan internet saya yg putus Click here to enlarge
    Jadi untuk mencegah user login pada saat itu saya buatlah 2 buah halaman login lain untuk memberitahu ke user, apa sebenarnya yg sedang terjadi.

    Halaman login menjadi 3 buah (folder)
    1. html5 <- aslinya
    Code:
    pamer dikit boleh ya.... :th_shiny_smile: 
    2. maintanance-lokal <- kalau akses ke server putus
    3. maintanance-internet <- kalau akses ke internet putus

    Berikut kode nya:
    Code:
    /tool netwatch
    add disabled=no down-script="/ip hotspot profile set 1 html-directory=\"maintanance-lokal\"\r\
        \n/tool netwatch disable 1" host=IP_LOKAL interval=1m timeout=1s \
        up-script="/ip hotspot profile set 1 html-directory=\"html5\"\r\
        \n/tool netwatch enable 1"
    add disabled=no down-script=\
        "/ip hotspot profile set 1 html-directory=\"maintanance-internet\"" host=\
        8.8.8.8 interval=1m timeout=1s up-script=\
        "/ip hotspot profile set 1 html-directory=\"html5\""
    Penjelasan:
    Rule 0, untuk memeriksa koneksi lokal, kalau down, rule 1 otomatis disable.
    Rule 1, untuk memeriksa koneksi internet.

    Maaf kata kalau kodenya lebih mudah dimengerti daripada penjelasannya.

  2. #2
    Status
    Offline
    Akangage's Avatar
    Administrator
    Join Date
    Aug 2007
    Location
    Daerah Khusus Ibukota Jakarta, Indonesia
    Posts
    4,195
    Reviews
    Read 0 Reviews
    Downloads
    210
    Uploads
    87
    Feedback Score
    0
    Masih ga ngerti gw gan Click here to enlarge di link youtube cuman login page doank Click here to enlarge

  3. The Following User Says Thank You to Akangage For This Useful Post:


  4. #3
    Status
    Offline
    borokovic's Avatar
    Newbie
    Join Date
    Oct 2009
    Location
    Aceh Singkil
    Posts
    55
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Iya gan, itu cuma buat pamer login page aja Click here to enlarge

    Oh ya gan... inikan tutz, tapi tag yg ada cuma ask sama solved, jadi saya pilih solved aja. Mohon dikoreksi kalau salah.. Click here to enlarge
    Last edited by borokovic; 03-11-2013 at 13:30.

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [ASK] Cara Setting Login Page Dengan Mikrotik
    By Robby Liaw in forum Wireless Networking
    Replies: 0
    Last Post: 25-02-2013, 12:35
  2. Login Page (halaman login) Hotspot di server eksternal
    By zlich in forum Beginner Basics
    Replies: 4
    Last Post: 16-07-2012, 00:29
  3. Replies: 15
    Last Post: 24-01-2012, 14:18
  4. gimana mengganti que secara otomatis dengan netwatch
    By rijanarko in forum Beginner Basics
    Replies: 3
    Last Post: 31-10-2011, 10:50
  5. Gimana membuat Hotspot Login agar bisa otomatis login dimikrotik
    By Orang Ganteng in forum General Networking
    Replies: 10
    Last Post: 27-05-2010, 22:02

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •