Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Results 1 to 6 of 6
  1. #1
    Status
    Offline
    Mikrolet's Avatar
    Newbie
    Join Date
    Sep 2012
    Posts
    24
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    Limit download Queue Tree tidak fungsi setelah internal web proxy di enable

    ini scriptnya gan..plis helep?
    /interface ethernet
    set 0 name=ether1-Speedy
    set 1 name=ether2-Hotspot

    /ip firewall layer7-protocol
    add name=Download regexp="^.*get.+\\.(c.youtube.com|exe|rar|zip|7z|c ab|asf|mov\
    |wmv|mpg|mpeg|mkv|avi|flv|pdf|wav|rm|mp3|mp4|ram|r mvb|dat|daa|iso|nrg|bin|\
    vcd|mp2|3gp|mpe|qt|raw|wma|ogg|doc|deb|tar|bzip|gz ip|gzip2|0[0-9][0-9]).*\
    \$"

    /queue tree
    add max-limit=256k name=Download packet-mark=Download parent=global queue=\
    shape
    add limit-at=32k max-limit=64k name="Proteksi DNS" packet-mark=c-dns parent=\
    global priority=1 queue=default
    add limit-at=32k max-limit=64k name=Proteksi-ICMP packet-mark=c-icmp parent=\
    global priority=1 queue=default
    add max-limit=1M name=QoS-Downstream parent=global priority=3 queue=default
    add limit-at=256k max-limit=512k name=HTTPS packet-mark=c-https parent=global \
    priority=1 queue=default
    add limit-at=256k max-limit=512k name=HTTP packet-mark=c-http parent=global \
    priority=3 queue=shape

    /ip address
    add address=192.168.0.2/24 interface=ether1-Speedy network=192.168.0.0
    add address=192.168.1.1/24 interface=ether2-Hotspot network=192.168.1.0

    /ip firewall mangle
    add action=mark-packet chain=prerouting comment=Mark-DNS dst-port=53 \
    new-packet-mark=c-dns protocol=tcp
    add action=mark-packet chain=prerouting comment=Mark-ICMP new-packet-mark=\
    c-icmp protocol=icmp
    add action=mark-packet chain=postrouting comment=Mark-HTTP dst-port=\
    80,8080,3128,8888 new-packet-mark=c-http protocol=tcp
    add action=mark-packet chain=postrouting comment=Mark-HTTPS dst-port=443 \
    new-packet-mark=c-https protocol=tcp
    add action=mark-packet chain=prerouting comment=Download layer7-protocol=\
    Download new-packet-mark=Download protocol=tcp


    /ip firewall nat
    add action=passthrough chain=unused-hs-chain comment=\
    "place hotspot rules here" disabled=yes to-addresses=0.0.0.0
    add action=masquerade chain=srcnat
    add action=redirect chain=dstnat dst-port=80,8080,8081 \
    in-interface=ether2-Hotspot protocol=tcp src-address=192.168.1.0/24 \
    to-ports=3128

    /ip proxy
    set cache-on-disk=yes enabled=yes port=3128
    /ip route
    add distance=1 gateway=192.168.0.1
    Last edited by Mikrolet; 12-09-2013 at 17:38.

  2. #2
    Status
    Offline
    Noeg Waskito's Avatar
    Member Senior
    Join Date
    Aug 2012
    Location
    Jogja
    Posts
    405
    Reviews
    Read 0 Reviews
    Downloads
    1
    Uploads
    0
    Feedback Score
    0
    tidak fungsi itu jebol atau malah kelimit?

  3. #3
    Status
    Offline
    Mikrolet's Avatar
    Newbie
    Join Date
    Sep 2012
    Posts
    24
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by Noeg Waskito Click here to enlarge
    tidak fungsi itu jebol atau malah kelimit?
    Jebol gan...speednya bablas, tapi dah bisa nih, saya tambahkan chain 1 lagi.
    /ip firewall mangle
    add action=mark-packet chain=output comment=Download layer7-protocol=\
    Download new-packet-mark=Download protocol=tcp
    Hasilnya download lewat proxy atau tidak lewat proxy terlimit Queue tree L7
    tapi timbul masalah lagi, proxy hit ikut kelimit Click here to enlarge
    Plis helep gan...

  4. #4
    Status
    Offline
    Noeg Waskito's Avatar
    Member Senior
    Join Date
    Aug 2012
    Location
    Jogja
    Posts
    405
    Reviews
    Read 0 Reviews
    Downloads
    1
    Uploads
    0
    Feedback Score
    0
    hitnya dimarking dulu

  5. #5
    Status
    Offline
    brutuz_1's Avatar
    VIP Member
    Join Date
    Feb 2010
    Posts
    790
    Reviews
    Read 0 Reviews
    Downloads
    3
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by Noeg Waskito Click here to enlarge
    hitnya dimarking dulu
    stujuu ma agan ini, untuk trafik HIT nya mesti di marking juga,,,,

    Code:
    chain=output protocol=tcp src-port=3128 out-interface=lan dscp=4 action=mark-packet new-packet-mark=HIT-pkt passthrough=no
    -taruh magle nya paling atas
    -tarik packet mark nya di queue
    -asusmsi dscp=4 (default) nya internal web proxy

  6. #6
    Status
    Offline
    Mikrolet's Avatar
    Newbie
    Join Date
    Sep 2012
    Posts
    24
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by Noeg Waskito Click here to enlarge
    hitnya dimarking dulu
    Click here to enlarge Originally Posted by brutuz_1 Click here to enlarge
    stujuu ma agan ini, untuk trafik HIT nya mesti di marking juga,,,,

    Code:
    chain=output protocol=tcp src-port=3128 out-interface=lan dscp=4 action=mark-packet new-packet-mark=HIT-pkt passthrough=no
    -taruh magle nya paling atas
    -tarik packet mark nya di queue
    -asusmsi dscp=4 (default) nya internal web proxy
    betul gan sudah sudah bisa, ditambahin baris ini paling atas
    Code:
    /ip firewall mangle
    add action=mark-packet chain=output comment="HIT TRAFFIC FROM PROXY" dscp=4 \
        new-packet-mark=proxy-hit out-interface=ether2-Hotspot passthrough=no
    Makasih agan semua, Problem SOLVED...
    Last edited by Mikrolet; 14-09-2013 at 12:59.

 

 

Thread Information

Users Browsing this Thread

There are currently 3 users browsing this thread. (0 members and 3 guests)

Similar Threads

  1. [Video Tuts] Mensetting cache proxy MT biar tidak kena limit Queue
    By okto_2005 in forum QOS & Traffic Shaping
    Replies: 57
    Last Post: 03-03-2015, 15:58
  2. Mangle internal web-proxy + queue tree
    By adh1et in forum Tutorial
    Replies: 38
    Last Post: 27-12-2013, 14:16
  3. Replies: 1
    Last Post: 22-04-2012, 10:42
  4. [Ask] Ada kebocoran di Queue Tree+Internal WebProxy Saya ?
    By brutuz_1 in forum General Networking
    Replies: 16
    Last Post: 14-11-2011, 13:44

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •