halo support mikrotik saya ada case lg nih kk

1. Hasil script OK (membatasi user active hotspot)
:if (:toarray [/ip hotspot active print count]>20) do={:foreach i in=[/ip hotspot active find radius=yes] do={:if ([/ip hotspot active get $i uptime]<=00:00:01) do={/ip hotspot active remove $i
:log info "Deleted New User Login - Limit Total Hotspot Active"}}};

2. nah yang ini saya mau nanya bagaimana membatasi user active hotspot yang memiliki mikrotik address-list=free-wifi sedangkan yang memiliki mikrotik address-list=non-free tidak terbatasi? (free = Limit dan nonfree = no limit)
saya baru bisa detect yang :if (:toarray [/ip firewall address-list print count where dynamic=yes list=free-wifi]>20) do=selanjutanya msh ngejlumet hihihi

thanks