Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Results 1 to 3 of 3
  1. #1
    Status
    Offline
    yuven3091's Avatar
    Baru Gabung
    Join Date
    Jul 2012
    Posts
    8
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    Pemisahan Bandwidth browsing dan download dan limit download .

    bagaimana cara memisahkan antara bandwidth untuk browsing dan bandwidth untuk download..?? (bandwidth speedy = 1 MB)

    Bandwidth untuk browsing dipakai 50 %.
    Bandwidth download dibagi lagi menjadi 2 :
    - untuk download segala jenis file di atas 5 MB memakan sekitar 30% dari total bandwidth.
    - untuk file2 kurang dari 5 MB, hanya memakan 20% dari total bandwidth..

    > kira-kira metode apa yang akan saya gunakan?
    mohon bantuannya . . Click here to enlargeClick here to enlarge

  2. #2
    Status
    Offline
    dhopack's Avatar
    Forum Guru
    Join Date
    Dec 2010
    Location
    KUDUS
    Posts
    1,919
    Reviews
    Read 0 Reviews
    Downloads
    2
    Uploads
    0
    Feedback Score
    0
    mungkin bisa coba pake metode conn-byte,
    CMIIW lho

  3. #3
    Status
    Offline
    Neo.Caliph's Avatar
    Baru Gabung
    Join Date
    Aug 2012
    Location
    Sengkaling, Malang
    Posts
    13
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    coba pake langkah2 ini:
    1. buat L7 filtering untuk mengenali tipe mime dari http requests,

    /ip firewall layer7-protocol
    add comment="" name="download" regexp="\\.(avi|ac4|mp(e?g|a|e|1|2|3|4)|mk(a|v)|og (x|v|a|g) |rm|r(a|p)m|vob|flv|x-flv|3gp|amr|klv|wav|DivX|mov|wmv|rmvb|aac|zip|rar| iso|exe)"

    2. setelah itu, bikin mangle rulenya

    /ip firewall mangle
    add action=mark-connection chain=prerouting protocol=tcp dst-port=53 new-connection-mark=c-dns passthrough=yes comment="Mark DNS"
    add action=mark-connection chain=prerouting protocol=udp dst-port=53 new-connection-mark=c-dns passthrough=yes
    add action=mark-packet chain= prerouting connection-mark=c-dns new-packet-mark=p-dns passthrough=no

    add action=mark-connection chain=prerouting protocol=icmp new-connection-mark=c-icmp passthrough=yes comment="Mark ICMP"
    add action=mark-packet chain=forward connection-mark=c-icmp new-packet-mark=p-icmp passthrough=no

    add action=mark-connection chain=postrouting protocol=tcp dst-port=80,8080,3128,8888 new-connection-mark=c-http passthrough=yes comment="Mark HTTP"
    add action=mark-packet chain=postrouting connection-mark=c-http new-packet-mark=p-http passthrough=no

    add action=mark-connection chain=postrouting protocol=tcp dst-port=443 new-connection-mark=c-https passthrough=yes comment="Mark HTTPS"
    add action=mark-packet chain=postrouting connection-mark=c-https new-packet-mark=p-https passthrough=no

    add action=mark-packet chain=postrouting layer7-protocol=download new-packet-mark=pl7-download passthrough=no comment="Mark File DOWNLOAD"

    3. Setelah itu buat Queue Treenya

    /queue tree
    add name=”1. Proteksi DNS” parent=global-out packet-mark=p-dns limit-at=32k max-limit=64k queue=default priority=1
    add name=”1. Proteksi ICMP” parent= global-out packet-mark=p-icmp limit-at=32k max-limit=64k queue=default priority=1

    add name=”2. QoS Downstream” parent=global-out max-limit=1M queue=default priority=3
    add name=”1. HTTPS” parent="2. QoS Downstream" packet-mark=p-https limit-at=256k max-limit=512k queue=default priority=1
    add name=”2. HTTP” parent="2. QoS Downstream" packet-mark=p-http limit-at=256k max-limit=512k queue=default priority=3

    add name=Download parent="2. QoS Downstream" packet-mark=pl7-download limit-at=256k max-limit=512k queue=default priority=8

    4. Selesai, logikanya sih begini, tuh rule bakan prioritas DNS dulu, terus memastikan ICMP packet dapet bandwidth, jadi ping harusnye ga bakal kriting, kemudian baru prioritas browsing, dimana protokol https lebih diutamakan dari pada protokol http, baru download ditaruh paling belakang.

    nih script belum ane belum sempat coba langsung, tapi harusnya jalan, moga2 berguna.

 

 

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Similar Threads

  1. Help Limit Download File and Bypass browsing hotspot
    By fazry in forum General Networking
    Replies: 14
    Last Post: 09-04-2012, 05:59
  2. Replies: 7
    Last Post: 05-12-2011, 23:00
  3. Replies: 1
    Last Post: 07-11-2011, 12:58
  4. Limiting Bandwidth, Upload+download+Browsing
    By hqki in forum General Networking
    Replies: 11
    Last Post: 05-02-2011, 17:18

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •