Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Results 1 to 8 of 8
  1. #1
    Status
    Offline
    benmikrotik's Avatar
    Baru Gabung
    Join Date
    Aug 2011
    Location
    Philippine Islands
    Posts
    5
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    Basic traffic shaping based on layer-7 protocol

    Hi All,

    I am really sorry I don't speak or understand Bahasa, I am just using online translator to understand the language. Still you can reply in Bahasa if you want to help me.

    Currently I have a working setup, using this:

    Though it works, I am having latency problems with online games like Crossfire, Counter strike source, etc..

    I want to prioritize online games.

    How do I add to my current layer 7 setup?

    Thanks in advance.

  2. #2
    Status
    Offline
    dhopack's Avatar
    Forum Guru
    Join Date
    Dec 2010
    Location
    KUDUS
    Posts
    1,919
    Reviews
    Read 0 Reviews
    Downloads
    2
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by benmikrotik Click here to enlarge
    ...
    I want to prioritize online games.
    ...
    maybe u can try this

    complex l7 takes a lot of resources(cpu load),
    CMIIW

  3. The Following User Says Thank You to dhopack For This Useful Post:


  4. #3
    Status
    Offline
    benmikrotik's Avatar
    Baru Gabung
    Join Date
    Aug 2011
    Location
    Philippine Islands
    Posts
    5
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by dhopack Click here to enlarge
    maybe u can try this

    complex l7 takes a lot of resources(cpu load),
    CMIIW
    Thanks. looks nice.
    Maybe I could try this one out.
    How about skype? Skype is a priority too.

  5. #4
    Status
    Offline
    m3tr0mini's Avatar
    Member Super Senior
    Join Date
    Sep 2007
    Posts
    660
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by benmikrotik Click here to enlarge
    Thanks. looks nice.
    Maybe I could try this one out.
    How about skype? Skype is a priority too.
    skype still using a port.... u can use janis maqis presentation ...QOS best practice..

  6. #5
    Status
    Offline
    benmikrotik's Avatar
    Baru Gabung
    Join Date
    Aug 2011
    Location
    Philippine Islands
    Posts
    5
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by m3tr0mini Click here to enlarge
    skype still using a port.... u can use janis maqis presentation ...QOS best practice..
    Any link?

    Thanks for the info.

  7. #6
    Status
    Offline
    Neo.Caliph's Avatar
    Baru Gabung
    Join Date
    Aug 2012
    Location
    Sengkaling, Malang
    Posts
    13
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    hi, ben, nice to meet you ^_^

    for games, you have to make sure your DNS and ICMP packets traffics have anough bandwith, and make sure to protect your online games port with anough bandwidth, try to use this configuration for first step



    then add game mangle, for example
    This one protecting DOTA and Zinga Poker from facebook

    /ip firewall mangle
    add chain=postrouting action=mark-connection protocol=tcp dst-port=6000-7152 new-connection-mark="cgo-dota" passthrough=yes comment="Mark Game Online DOTA"
    add chain=postrouting action=mark-packet connection-mark=cgo-dota new-packet-mark=pgo-dota passthrough=no
    add action=mark-connection chain=postrouting protocol=tcp src-port=9339 new-connection-mark=cgf-zyngapoker passthrough=yes comment="Mark Game Facebook Zynga Poker"
    add action=mark-packet chain= postrouting connection-mark=cgf-zyngapoker new-packet-mark=pgf-zyngapoker passthrough=no

    /queue tree
    add name=”1. DOTA” parent="2. QoS Downstream” packet-mark=pgo-dota limit-at=256k max-limit=512k queue=default priority=1
    add name=”1. Zynga Poker” parent="2. QoS Downstream" packet-mark=pgf-zyngapoker limit-at=256k max-limit=512k queue=default priority=1

    hope it help you, you can just customize the rules, to fullfill your needs ^_^

    oh for skype, that one is complicated, skype use different port everytime you connect to server and have different pattern header each update, I am still learn about it....

  8. #7
    Status
    Offline
    m3tr0mini's Avatar
    Member Super Senior
    Join Date
    Sep 2007
    Posts
    660
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by benmikrotik Click here to enlarge
    Any link?

    Thanks for the info.
    Code:
    http://mum.mikrotik.com/presentations/US08/janism.pdf

  9. The Following User Says Thank You to m3tr0mini For This Useful Post:


  10. #8
    Status
    Offline
    benmikrotik's Avatar
    Baru Gabung
    Join Date
    Aug 2011
    Location
    Philippine Islands
    Posts
    5
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by m3tr0mini Click here to enlarge
    Code:
    http://mum.mikrotik.com/presentations/US08/janism.pdf
    Thanks a lot. I did use this guide. So far it's working good.

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [ASK] Traffic Shaping dengan Queue Tree
    By iif in forum General Networking
    Replies: 8
    Last Post: 28-09-2016, 15:03
  2. [share] traffic shaping queue(very basic)
    By Anto.PJ in forum Beginner Basics
    Replies: 7
    Last Post: 12-08-2012, 22:45
  3. Replies: 5
    Last Post: 11-12-2010, 22:57
  4. Replies: 3
    Last Post: 21-05-2010, 08:54
  5. [ASk] Antrian/queue ada di layer brp dalam OSI layer?
    By princess in forum General Networking
    Replies: 1
    Last Post: 28-02-2010, 23:54

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •