Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Results 1 to 5 of 5
  1. #1
    Status
    Offline
    chrone's Avatar
    Calon Member
    Join Date
    Mar 2008
    Posts
    95
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    [help] bandwidth management ok di ros v2.9.51, tetapi tidak jalan di ros v3.7

    dear all,

    saya suka dengan feature baru dari v3.x di mana hit cache web-proxy tidak ikut ke limit queue, hanya saja proxy di versi 3.7 yang saya pakai sepertinya tidak maksimal kerjanya mengingat ada beberapa situs yang tidak bisa ke cache image2nya (contoh apple.com), sedangkan pada ros v2.9.51 bisa.


    adapun menggunakan konfigurasi yang sama dengan v2.9.51 untuk bandwidth managementnya, menggunakan pcq untuk equal bandwidth sharing among users yang berhasil dijalankan walaupun client menggunakan download manager.

    sayangnya tidak berhasil di ros v3.7 ini. saya bingung apakah konfigurasi mangle, queue type, dan queue tree ada yang berubah untuk versi 3.7 sehingga jika ada klien yang download make download manager, pc yang lain sangat sedikit mendapatkan bandwidth, padahal pcq dan queue saya berjalan sangat baik di ros v2.9.51. Click here to enlarge

    berikut konfigurasi saya di ros v3.7:
    5 chain=dstnat action=redirect to-ports=3128 src-address=192.168.0.0/24 in-interface=local dst-port=80 protocol=tcp
    15 ;;; proxy indosat
    chain=output action=mark-packet new-packet-mark=proxy
    passthrough=no dst-address-list=indosat out-interface=local dscp=4

    16 ;;; indosat
    chain=prerouting action=mark-routing new-routing-mark=indosat
    passthrough=yes src-address-list=indosat

    17 chain=prerouting action=mark-packet new-packet-mark=indosat-upload
    passthrough=no dst-address=!192.168.0.0/24 routing-mark=indosat
    in-interface=local

    18 chain=forward action=mark-connection
    new-connection-mark=indosat-connection passthrough=yes
    routing-mark=indosat

    19 chain=forward action=mark-packet new-packet-mark=indosat-download
    passthrough=no in-interface=indosat
    connection-mark=indosat-connection

    20 chain=output action=mark-packet new-packet-mark=indosat-download
    passthrough=no dst-address-list=indosat out-interface=local
    src-port=!8291 protocol=tcp
    4 name="indosat-upload" parent=indosat-up packet-mark=indosat-upload limit-at=0 queue=pcq-upload priority=8
    max-limit=496000 burst-limit=0 burst-threshold=0 burst-time=0s

    5 name="indosat-download" parent=indosat-down packet-mark=indosat-download limit-at=0 queue=pcq-download priority=8
    max-limit=496000 burst-limit=0 burst-threshold=0 burst-time=0s

    6 name="indosat-down" parent=local packet-mark="" limit-at=0 queue=default priority=8 max-limit=512000 burst-limit=0
    burst-threshold=0 burst-time=0s

    7 name="indosat-up" parent=global-in packet-mark="" limit-at=0 queue=default priority=8 max-limit=512000 burst-limit=0
    burst-threshold=0 burst-time=0s
    enabled: yes
    src-address: 0.0.0.0
    port: 3128
    parent-proxy: 0.0.0.0
    parent-proxy-port: 0
    cache-drive: secondary-master
    cache-administrator: "webmaster"
    max-cache-size: unlimited
    cache-on-disk: yes
    max-client-connections: 600
    max-server-connections: 600
    max-fresh-time: 3d
    serialize-connections: no
    always-from-cache: no
    cache-hit-dscp: 4
    sedangkan konfigurasi untuk ros v2.9.51 kurang lebih sama hanya saja saya tidak memakai web-proxy dan chain=output karena masih belum bisa mem-bypass hit cache proxy sehingga baik menggunakan proxy atau tidak, rasanya sama saja karena terlimit oleh queue saya.

    ada yang mempunyai pengalaman saya? ataukah ada yang bisa membenarkan mangle atau queue saya?

    saya inginnya bisa memakai web-proxy (istilah web-proxy ini di v3.7 diubah menjadi proxy saja) dengan tetap equal bandwidth sharing among user untuk bandwidth managementnya.

    terima kasih sebelumnya.

  2. #2
    Status
    Offline
    ponywaterhouse's Avatar
    Forum Guru
    Join Date
    Jul 2007
    Posts
    1,507
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    mas..

    Code:
    enabled: yes
    src-address: 0.0.0.0
    port: 3128
    parent-proxy: 0.0.0.0
    parent-proxy-port: 0
    cache-drive: secondary-master
    cache-administrator: "webmaster"
    max-cache-size: unlimited
    cache-on-disk: yes
    max-client-connections: 600
    max-server-connections: 600
    max-fresh-time: 3d
    serialize-connections: no
    always-from-cache: no
    cache-hit-dscp: 4
    coba serialize-connection nya di yes kan
    always-from-cache juga di yes kan..

    saya juga pake metode ini di warnet, dan bisa berkerja dng baik..

  3. The Following User Says Thank You to ponywaterhouse For This Useful Post:


  4. #3
    Status
    Offline
    doejhon's Avatar
    Newbie
    Join Date
    Aug 2007
    Posts
    36
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    /ip firewall mangle
    add action=mark-packet chain=output comment="cached packets" disabled=no \
    dscp=4 new-packet-mark=cached out-interface=!Lan passthrough=no
    /queue simple
    add comment="" direction=both disabled=no dst-address=0.0.0.0/0 interface=all \
    limit-at=0/0 max-limit=0/0 name="cached" packet-marks=cached parent=none \
    priority=8 queue=default-small/default-small \
    target-addresses=192.168.0.0/16 total-queue=default-small

    mungkin sedikit tambahan bisa berguna atau tidak tapi cukup membantu Click here to enlarge

  5. The Following User Says Thank You to doejhon For This Useful Post:


  6. #4
    Status
    Offline
    chrone's Avatar
    Calon Member
    Join Date
    Mar 2008
    Posts
    95
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by ponywaterhouse Click here to enlarge
    mas..

    Code:
    enabled: yes
    src-address: 0.0.0.0
    port: 3128
    parent-proxy: 0.0.0.0
    parent-proxy-port: 0
    cache-drive: secondary-master
    cache-administrator: "webmaster"
    max-cache-size: unlimited
    cache-on-disk: yes
    max-client-connections: 600
    max-server-connections: 600
    max-fresh-time: 3d
    serialize-connections: no
    always-from-cache: no
    cache-hit-dscp: 4
    coba serialize-connection nya di yes kan
    always-from-cache juga di yes kan..

    saya juga pake metode ini di warnet, dan bisa berkerja dng baik..
    bandwidth managementnya (pcq for equal bandwidth sharing) bekerja dengan baik??

    test yang saya gunakan menggunakan download manager download express dari metaproducts.com untuk file installer debian iso cd pertama dari debian.org, setelah download agak lama (icon queue tree berwarna merah), equal bandwidth sharing tidak terjadi di mikrotik ros v3.7. Click here to enlarge

    saya udah coba set proxynya seperti yang anda bilang di atas dan hasilnya sama saja apabila saya coba download make download manager yang ngebagi downloadnya menjadi beberapa link download (7 link tepatnya) dan hasilnya kurang memuaskan. pc klien lain sangat sedikit mendapatkan bandwidth dan kurang responsif browsing dari klien lain.

    saya coba disable settingan proxynya, dst-nat untuk proxy, dan chain output untuk proxy sehingga mikrotik jalan tanpa proxy, dan hasilnya juga sama tidak bisa membagi rata bandwidth.

    hasilnya sangat berbeda dengan ROS v2.9.x di mana konfigurasi pcq, queue tree, dan mangle saya berhasil untuk bandwidth management equal sharing meskipun ada yang download make download manager, tetapi dari pc klien lainnya masih responsif untuk browsing dan bandwidth langsung otomatis terbagi rata (liat dari torch).

    btw, terima kasih infonya, saya coba lagi besok. Click here to enlarge

    oia saya kelupaan nanya juga, menggunakan proxy dari ROS v3.x ini, apakah anda bisa cache image headline dari apple.com? saya coba di ros v2.9.x, situs apple.com ke-cached, tetapi di ros v3.x situs apple.com tidak ter-cached.
    Last edited by chrone; 04-05-2008 at 22:31.

  7. #5
    Status
    Offline
    chrone's Avatar
    Calon Member
    Join Date
    Mar 2008
    Posts
    95
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by doejhon Click here to enlarge
    /ip firewall mangle
    add action=mark-packet chain=output comment="cached packets" disabled=no \
    dscp=4 new-packet-mark=cached out-interface=!Lan passthrough=no
    /queue simple
    add comment="" direction=both disabled=no dst-address=0.0.0.0/0 interface=all \
    limit-at=0/0 max-limit=0/0 name="cached" packet-marks=cached parent=none \
    priority=8 queue=default-small/default-small \
    target-addresses=192.168.0.0/16 total-queue=default-small

    mungkin sedikit tambahan bisa berguna atau tidak tapi cukup membantu Click here to enlarge
    terima kasih mas infonya. Click here to enlarge

    tetapi di ROS v3.7 hal ini sudah bisa diatasi dengan set mangle "chain=output dscp=4 action=mark-packet new-packet-mark=proxy passthrough=no" dan ditaruh di atas chain=output yang ngatur bandwidth proxy. Click here to enlarge

    mungkin anda tahu bagaimana cara bypass hit cache web-proxy di ROS v2.9x??

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Bandwidth management di Hotspot Area
    By okto_2005 in forum QOS & Traffic Shaping
    Replies: 46
    Last Post: 04-12-2012, 21:40
  2. setting web proxy, rule firewall jadi tidak jalan
    By carrud in forum General Networking
    Replies: 6
    Last Post: 17-09-2010, 13:39
  3. (tanya) outlook tidak bisa jalan
    By gunsie in forum Beginner Basics
    Replies: 28
    Last Post: 04-04-2008, 11:40
  4. [Ask] DHCP Bandwidth Management ?
    By lylyk in forum Beginner Basics
    Replies: 1
    Last Post: 18-12-2007, 12:23
  5. ni soal bandwidth management..plz
    By emmerdale in forum Beginner Basics
    Replies: 3
    Last Post: 28-10-2007, 12:01

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •