maap gan lg belajar internal proxy Click here to enlarge
inet --- mikrotik (internal proxy) ---- client
mikrotik 3.2
ip internet 192.168.1.1
ip mikrotik 192.168.100.1

kenapa klo untuk internal proxy, cache proxy kena limit juga ya

/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=128000 max-limit=\
2000000 name=DnLoud packet-mark="" parent=ether2 priority=2 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=128000 max-limit=\
750000 name=Browsing packet-mark=Browsing parent=DnLoud priority=7 queue=Auto_Down
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=128000 max-limit=\
750000 name=Download packet-mark=D_load parent=DnLoud priority=8 queue=Auto_Down
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 \
name=Game packet-mark=Game parent=DnLoud priority=1 queue=Auto_Down
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=64000 max-limit=\
512000 name=UpLoad packet-mark="" parent=ether1 priority=1 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=64000 max-limit=\
100000 name=Browsing_Up packet-mark=Browsing parent=UpLoad priority=7 queue=Auto_Up
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 \
name=Game_Up packet-mark=Game parent=UpLoad priority=1 queue=Auto_Up
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=65000 max-limit=\
100000 name=File_Up packet-mark=D_load parent=UpLoad priority=8 queue=Auto_Up
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=64000 max-limit=\
800000 name=HotSpot_Dn packet-mark="" priority=8 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=0 max-limit=0 \
name=Hot_Down packet-mark="" parent=HotSpot_Dn priority=5 queue=Auto_Down
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=0 max-limit=0 \
name=Hot_File packet-mark="" parent=HotSpot_Dn priority=8 queue=Auto_Down
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=2000000 \
max-limit=30000000 name=Proxy packet-mark=proxy-hit parent=ether2 priority=8 queue=\
Proxy
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=2000000 \
max-limit=8000000 name=Squid packet-mark=proxy-Squid parent=ether2 priority=8 queue=\
default
[admin@Game War] /queue tree>


/ip firewall mangle
add action=mark-connection chain=postrouting comment=PB-UDP disabled=no \
dst-address-list=nice dst-port=40000-40010 new-connection-mark=game-online-indonesia \
passthrough=yes protocol=udp
add action=mark-connection chain=postrouting comment=PB-TCP disabled=no \
dst-address-list=nice dst-port=39000-40000,49100 new-connection-mark=\
game-online-indonesia passthrough=yes protocol=tcp
add action=mark-connection chain=postrouting comment="X-Shot UDP" disabled=no \
dst-address-list=nice dst-port=7777-7977,30000 new-connection-mark=\
game-online-indonesia passthrough=yes protocol=udp
add action=mark-connection chain=postrouting comment="Cross Fire TCP" disabled=no \
dst-address-list=nice dst-port=10009,13008,16666,28012 new-connection-mark=\
game-online-indonesia passthrough=yes protocol=tcp
add action=mark-connection chain=postrouting comment="Cross Fire UDP" disabled=no \
dst-address-list=nice dst-port=12020-12080,13000-13080 new-connection-mark=\
game-online-indonesia passthrough=yes protocol=udp
add action=mark-connection chain=postrouting comment="CounterStrike Online UDP" \
disabled=no dst-address-list=nice dst-port=41000-42000,27017 new-connection-mark=\
game-online-indonesia passthrough=yes protocol=udp
add action=mark-connection chain=postrouting comment="CounterStrike Online TCP" \
disabled=no dst-address-list=nice dst-port=8001,8005,9015,40300-40404,36567 \
new-connection-mark=game-online-indonesia passthrough=yes protocol=tcp
add action=mark-connection chain=postrouting comment="Lost Saga TCP" disabled=no \
dst-address-list=nice dst-port=14009-14010 new-connection-mark=game-online-indonesia \
passthrough=yes protocol=tcp
add action=mark-connection chain=postrouting comment="Lost Saga UDP" disabled=no \
dst-address-list=nice dst-port=14009,14010 new-connection-mark=game-online-indonesia \
passthrough=yes protocol=udp
add action=mark-connection chain=postrouting comment=RF-Elven disabled=no \
dst-address-list=nice dst-port=27780 new-connection-mark=game-online-indonesia \
passthrough=yes protocol=tcp
add action=mark-connection chain=postrouting comment="Zeus RO" disabled=no \
dst-address-list=nice dst-port=5121 new-connection-mark=game-online-indonesia \
passthrough=yes protocol=tcp
add action=mark-connection chain=postrouting comment=DOTA disabled=no dst-address-list=\
nice dst-port=6000-6125 new-connection-mark=game-online-indonesia passthrough=yes \
protocol=tcp
add action=mark-connection chain=postrouting comment="Crazy Kart" disabled=no \
dst-address-list=nice dst-port=9600-9602 new-connection-mark=game-online-indonesia \
passthrough=yes protocol=tcp
add action=mark-connection chain=postrouting comment="Crazy Kart 2" disabled=no \
dst-address-list=nice dst-port=9600 new-connection-mark=game-online-indonesia \
passthrough=yes protocol=tcp
add action=mark-connection chain=postrouting comment="Free Style TCP" disabled=no \
dst-address-list=nice dst-port=10001-10011,40000 new-connection-mark=\
game-online-indonesia passthrough=yes protocol=tcp
add action=mark-connection chain=postrouting comment="Free Style UDP" disabled=no \
dst-address-list=nice dst-port=40040-40500,1293,1479 new-connection-mark=\
game-online-indonesia passthrough=yes protocol=udp
add action=mark-connection chain=postrouting comment="Luna Online" disabled=no \
dst-address-list=nice dst-port=15000-15002 new-connection-mark=game-online-indonesia \
passthrough=yes protocol=tcp
add action=mark-connection chain=postrouting comment="Drift City" disabled=no \
dst-address-list=nice dst-port=11011-11041 new-connection-mark=game-online-indonesia \
passthrough=yes protocol=tcp
add action=mark-connection chain=postrouting comment="War Rock" disabled=no \
dst-address-list=nice dst-port=5340-5352 new-connection-mark=game-online-indonesia \
passthrough=yes protocol=tcp
add action=mark-connection chain=postrouting comment="Ayo Dance" disabled=no \
dst-address-list=nice dst-port=18900-18910 new-connection-mark=game-online-indonesia \
passthrough=yes protocol=tcp
add action=mark-connection chain=postrouting comment="Seal Online" disabled=no \
dst-address-list=nice dst-port=1818 new-connection-mark=game-online-indonesia \
passthrough=yes protocol=tcp
add action=mark-connection chain=postrouting comment="Lineage 2" disabled=no \
dst-address-list=nice dst-port=7777 new-connection-mark=game-online-indonesia \
passthrough=yes protocol=tcp
add action=mark-connection chain=postrouting comment=IDS disabled=no dst-address-list=\
nice dst-port=2001 new-connection-mark=game-online-indonesia passthrough=yes \
protocol=tcp
add action=mark-connection chain=postrouting comment="Ghost Online" disabled=no \
dst-address-list=nice dst-port=19101 new-connection-mark=game-online-indonesia \
passthrough=yes protocol=tcp
add action=mark-connection chain=postrouting comment="Perfect World" disabled=no \
dst-address-list=nice dst-port=29000 new-connection-mark=game-online-indonesia \
passthrough=yes protocol=tcp
add action=mark-connection chain=postrouting comment=Rohan disabled=no dst-address-list=\
nice dst-port=22100 new-connection-mark=game-online-indonesia passthrough=yes \
protocol=tcp
add action=mark-connection chain=postrouting comment="WOW AMPM" disabled=no \
dst-address-list=nice dst-port=8085 new-connection-mark=game-online-indonesia \
passthrough=yes protocol=tcp
add action=mark-connection chain=postrouting comment=GetAmped disabled=no \
dst-address-list=nice dst-port=13413 new-connection-mark=game-online-indonesia \
passthrough=yes protocol=tcp
add action=mark-connection chain=postrouting comment=Yullgang disabled=no \
dst-address-list=nice dst-port=19000 new-connection-mark=game-online-indonesia \
passthrough=yes protocol=tcp
add action=mark-connection chain=postrouting comment="RAN Online" disabled=no \
dst-address-list=nice dst-port=5105 new-connection-mark=game-online-indonesia \
passthrough=yes protocol=tcp
add action=mark-connection chain=postrouting comment="Fast Black" disabled=no \
dst-address-list=nice dst-port=6000-6001 new-connection-mark=game-online-indonesia \
passthrough=yes protocol=tcp
add action=mark-connection chain=postrouting comment="Rose Online" disabled=no \
dst-address-list=nice dst-port=29200 new-connection-mark=game-online-indonesia \
passthrough=yes protocol=tcp
add action=mark-connection chain=postrouting comment="Return of Warrior" disabled=no \
dst-address-list=nice dst-port=10402 new-connection-mark=game-online-indonesia \
passthrough=yes protocol=tcp
add action=mark-connection chain=postrouting comment="Runes of Magic" disabled=no \
dst-address-list=nice dst-port=16400-16502 new-connection-mark=game-online-indonesia \
passthrough=yes protocol=tcp
add action=mark-connection chain=postrouting comment="Fresh Ragnarok PS" disabled=no \
dst-address-list=nice dst-port=5171 new-connection-mark=game-online-indonesia \
passthrough=yes protocol=tcp
add action=mark-connection chain=postrouting comment="Tantra Online" disabled=no \
dst-address-list=nice dst-port=3010 new-connection-mark=game-online-indonesia \
passthrough=yes protocol=tcp
add action=mark-connection chain=postrouting comment=Atlantica disabled=no \
dst-address-list=nice dst-port=4300 new-connection-mark=game-online-indonesia \
passthrough=yes protocol=tcp
add action=mark-connection chain=postrouting comment="ECO Online" disabled=no \
dst-address-list=nice dst-port=12011,12110 new-connection-mark=game-online-indonesia \
passthrough=yes protocol=tcp
add action=mark-connection chain=postrouting comment="Cabal Indonesia" disabled=no \
dst-address-list=nice dst-port=15000-15002 new-connection-mark=game-online-indonesia \
passthrough=yes protocol=tcp
add action=mark-connection chain=postrouting comment=Avalon disabled=no \
dst-address-list=nice dst-port=9376-9377 new-connection-mark=game-online-indonesia \
passthrough=yes protocol=tcp
add action=mark-connection chain=postrouting comment="3 Kingdoms" disabled=no \
dst-address-list=nice dst-port=15000-15002 new-connection-mark=game-online-indonesia \
passthrough=yes protocol=udp
add action=mark-connection chain=postrouting comment="Grand Chase TCP" disabled=no \
dst-address-list=nice dst-port=9300,9400,9700 new-connection-mark=\
game-online-indonesia passthrough=yes protocol=tcp
add action=mark-connection chain=postrouting comment="Grand Chase UDP" disabled=no \
dst-address-list=nice dst-port=9401,9600 new-connection-mark=game-online-indonesia \
passthrough=yes protocol=udp
add action=mark-connection chain=postrouting comment=MAKO disabled=no dst-address-list=\
nice dst-port=21000-21020 new-connection-mark=game-online-indonesia passthrough=yes \
protocol=tcp
add action=mark-packet chain=postrouting comment="Game Online" connection-mark=\
game-online-indonesia disabled=no new-packet-mark=Game passthrough=yes
add action=mark-packet chain=postrouting comment=Browsing connection-mark=\
!game-online-indonesia disabled=no new-packet-mark=Browsing passthrough=yes
add action=mark-connection chain=postrouting comment=EXE connection-mark=\
!game-online-indonesia content=.exe disabled=no new-connection-mark=IDM passthrough=\
yes
add action=mark-connection chain=postrouting comment=ZIP connection-mark=\
!game-online-indonesia content=.zip disabled=no new-connection-mark=IDM passthrough=\
yes
add action=mark-connection chain=postrouting comment=RAR connection-mark=\
!game-online-indonesia content=.rar disabled=no new-connection-mark=IDM passthrough=\
yes
add action=mark-connection chain=postrouting comment=FLV connection-mark=\
!game-online-indonesia content=.flv disabled=no new-connection-mark=IDM passthrough=\
yes
add action=mark-connection chain=postrouting comment=3GP connection-mark=\
!game-online-indonesia content=.3gp disabled=no new-connection-mark=IDM passthrough=\
yes
add action=mark-connection chain=postrouting comment=ISO connection-mark=\
!game-online-indonesia content=.iso disabled=no new-connection-mark=IDM passthrough=\
yes
add action=mark-connection chain=postrouting comment=NRG connection-mark=\
!game-online-indonesia content=.ngr disabled=no new-connection-mark=IDM passthrough=\
yes
add action=mark-connection chain=postrouting comment=MPG connection-mark=\
!game-online-indonesia content=.mpg disabled=no new-connection-mark=IDM passthrough=\
yes
add action=mark-connection chain=postrouting comment=MOV connection-mark=\
!game-online-indonesia content=.mov disabled=no new-connection-mark=IDM passthrough=\
yes
add action=mark-connection chain=postrouting comment=MP4 connection-mark=\
!game-online-indonesia content=.mp4 disabled=no new-connection-mark=IDM passthrough=\
yes
add action=mark-connection chain=postrouting comment=AVI connection-mark=\
!game-online-indonesia content=.avi disabled=no new-connection-mark=IDM passthrough=\
yes
add action=mark-connection chain=postrouting comment=MPEG connection-mark=\
!game-online-indonesia content=.mpeg disabled=no new-connection-mark=IDM \
passthrough=yes
add action=mark-connection chain=postrouting comment=WAV connection-mark=\
!game-online-indonesia content=.wav disabled=no new-connection-mark=IDM passthrough=\
yes
add action=mark-connection chain=postrouting comment=WMV connection-mark=\
!game-online-indonesia content=.wmv disabled=no new-connection-mark=IDM passthrough=\
yes
add action=mark-connection chain=postrouting comment=AAC connection-mark=\
!game-online-indonesia content=.aac disabled=no new-connection-mark=IDM passthrough=\
yes
add action=mark-connection chain=postrouting comment=MP3 connection-mark=\
!game-online-indonesia content=.mp3 disabled=no new-connection-mark=IDM passthrough=\
yes
add action=mark-connection chain=postrouting comment=Youtube connection-mark=\
!game-online-indonesia content=youtube disabled=no new-connection-mark=IDM \
passthrough=yes
add action=mark-connection chain=postrouting comment="Compress 001" connection-mark=\
!game-online-indonesia content=.00 disabled=no new-connection-mark=IDM passthrough=\
yes
add action=mark-connection chain=postrouting comment=PDF connection-mark=\
!game-online-indonesia content=.pdf disabled=no new-connection-mark=IDM passthrough=\
yes
add action=mark-connection chain=postrouting comment=DAT connection-mark=\
!game-online-indonesia content=.dat disabled=no new-connection-mark=IDM passthrough=\
yes
add action=mark-connection chain=postrouting comment=7z connection-mark=\
!game-online-indonesia content=.7z disabled=no new-connection-mark=IDM passthrough=\
yes
add action=mark-connection chain=postrouting comment=tar connection-mark=\
!game-online-indonesia content=.tar disabled=no new-connection-mark=IDM passthrough=\
yes
add action=mark-connection chain=postrouting comment=watch connection-mark=\
!game-online-indonesia content=watch disabled=no new-connection-mark=IDM \
passthrough=yes
add action=mark-connection chain=postrouting comment=MSI connection-mark=\
!game-online-indonesia content=.msi disabled=no new-connection-mark=IDM passthrough=\
yes
add action=mark-connection chain=postrouting comment=AMR connection-mark=\
!game-online-indonesia content=.amr disabled=no new-connection-mark=IDM passthrough=\
yes
add action=mark-packet chain=postrouting comment="File D_load" connection-mark=IDM \
disabled=no new-packet-mark=D_load passthrough=no
add action=mark-packet chain=output comment="HIT TRAFFIC FROM PROXY" disabled=no dscp=4 \
new-packet-mark=proxy-hit out-interface=ether2 passthrough=no
[admin@Game War] /ip firewall mangle>

tapi klo external proxy sejajar dengan client cache proxy ngak ikut terlimit
inet --- mikrotik --- proxy
------------------- client