Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Results 1 to 3 of 3
  1. #1
    Status
    Offline
    akai.tenshi's Avatar
    Baru Gabung
    Join Date
    Apr 2010
    Posts
    5
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    per-traffic of load balancing

    halo om..maaf newbie numpang tanya..
    saya kan punya modem Smart sama M2..
    nah niatnya mw coba implementasi Per-Traffic Load Balancing..
    jadi setiap orang yang browsing&email doang,masuk jalur M2..
    kalo mw download, masuk jalur Smart..

    liat sumbernya sih dari sini=

    saya modifikasi dikit, saya tambahin traffic FTP juga tuk jalur Smart.
    nah saya dah coba gini nih topologinya..
    Click here to enlarge
    Click here to enlarge nih scriptnya:
     

    / ip firewall address-list
    add list="Akses-Internet" address=192.168.3.0/24
    / ip firewall address-list
    add list="LAN-1" address=192.168.3.2-192.168.3.10
    add list="LAN-2" address=192.168.3.11-192.168.3.20
    / ip firewall nat
    add chain=srcnat action=masquerade out-interface="ISP-1" src-address-list="Akses-Internet"
    add chain=srcnat action=masquerade out-interface="ISP-2" src-address-list="Akses-Internet"
    /ip firewall mangle
    add chain=prerouting action=mark-routing new-routing-mark="LAN-1" src-address-list="LAN-1" passthrough=no
    add chain=prerouting action=mark-routing new-routing-mark="LAN-2" src-address-list="LAN-2" passthrough=no
    add chain=prerouting action=mark-routing new-routing-mark="HTTP traffic" passthrough=no dst-port=80 protocol=tcp
    add chain=prerouting action=mark-routing new-routing-mark="SSL traffic" passthrough=no dst-port=443 protocol=tcp
    add chain=prerouting action=mark-routing new-routing-mark="POP3 traffic" passthrough=no dst-port=110 protocol=tcp
    add chain=prerouting action=mark-routing new-routing-mark="SMTP traffic" passthrough=no dst-port=25 protocol=tcp
    add chain=prerouting action=mark-routing new-routing-mark="FTP traffic" passthrough=no dst-port=21 protocol=tcp
    add chain=prerouting action=mark-routing new-routing-mark="P2P traffic" passthrough=no p2p=all-p2p
    add chain=prerouting action=mark-routing new-routing-mark="Unknown traffic" passthrough=no
    /ip route
    add gateway=192.168.1.2 #perlu ga nih om?
    add gateway=192.168.2.2 #perlu ga nih om?
    add dst-address=0.0.0.0/0 gateway=192.168.1.1 scope=255 target-scope=10 routing-mark="LAN-1"
    add dst-address=0.0.0.0/0 gateway=192.168.2.1 scope=255 target-scope=10 routing-mark="LAN-2"
    add dst-address=0.0.0.0/0 gateway=192.168.1.1 scope=255 target-scope=10 routing-mark="HTTP traffic"
    add dst-address=0.0.0.0/0 gateway=192.168.1.1 scope=255 target-scope=10 routing-mark="SSL traffic"
    add dst-address=0.0.0.0/0 gateway=192.168.1.1 scope=255 target-scope=10 routing-mark="POP3 traffic"
    add dst-address=0.0.0.0/0 gateway=192.168.1.1 scope=255 target-scope=10 routing-mark="SMTP traffic"
    add dst-address=0.0.0.0/0 gateway=192.168.2.1 scope=255 target-scope=10 routing-mark="FTP traffic"
    add dst-address=0.0.0.0/0 gateway=192.168.2.1 scope=255 target-scope=10 routing-mark="P2P traffic"
    add dst-address=0.0.0.0/0 gateway=192.168.2.1 scope=255 target-scope=10 routing-mark="Unknown traffic"


    sekarang udah dicoba koneksi internet pake 1 PC sih bisa..
    tapi saya punya pertanyaan nih om..
    1. Bener ga tuh script load balancing yang saya buat? kira2 tambahin apa lagi ya?
    2. Kalo liat di Winbox -> Route List. masih ada yang unreachable. knp tuh?nih skrinsutnya.
    Click here to enlarge
    3. Monitoring Pake apa ya om, biar saya tau kalo emang traffic HTTP, POP3, SMTP udah masuk jalur IM2 dan kalo P2P dan FTP udah pasti hanya masuk di jalur Smart? ditesnya pake apa? monitoringnya pake apa? graph, Ntop ato apa?
    4. untuk script fail over untuk load balancing kaya gini, kira2 gmn ya om?

    Terimakasih Sebelumnya..

    salam dari Newbie yang numpang belajar Click here to enlarge

  2. #2
    Status
    Offline
    princekazaf1's Avatar
    Newbie
    Join Date
    Jan 2011
    Posts
    55
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge

    masih nubi ikut,,nyundulu dulu aja gan..

    Click here to enlarge

  3. #3
    Status
    Offline
    adiputrolds's Avatar
    Forum Guru
    Join Date
    Oct 2008
    Posts
    1,485
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    masih salah penerapannya mas bro

    anda mau membagi traffic berdasarkan dst-port atau pembagian traffic berdasarkan src-address-list ?

    default-route tanpa routing-mark hanya 1 mas bro
    gk bs 2
    route nya jadi error karena distance sama2 = 0
    kalo mau buat failover bikin salah satu gateway distance=1

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 98
    Last Post: 05-06-2015, 10:08
  2. Tanya Load Balancing Per traffic
    By akai.tenshi in forum General Networking
    Replies: 0
    Last Post: 11-03-2011, 16:15
  3. Tanya Load Balancing Per traffic
    By akai.tenshi in forum Beginner Basics
    Replies: 0
    Last Post: 11-03-2011, 15:06
  4. Tanya Load Balancing Per traffic
    By akai.tenshi in forum Beginner Basics
    Replies: 0
    Last Post: 11-03-2011, 14:58
  5. Load balancing di belakang load balancing
    By banana in forum General Networking
    Replies: 13
    Last Post: 09-06-2009, 15:38

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •