Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Results 1 to 1 of 1
  1. #1
    Status
    Offline
    oscark007's Avatar
    Member
    Join Date
    Jul 2010
    Posts
    116
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    [SAHRE] Simpan Dynamic IP pada Address-List

    Nubi mau share nih..

    awalnya saya ingin menyimpan daftar ip dinamik yang ada di address list yang berasal dari firewall filter.

    setelah cari2, muter muter yang saya dapatkan seperti ini:

    Code:
        :local comment
        :local address
        :local list
        :local disabled
    
        /ip firewall address-list
        :foreach a in=[find] do={
        :if ([get $a dynamic] = true) do={
        :set comment [get $a comment]
        :set address [get $a address]
        :set list [get $a list]
        :set disabled [get $a disabled]
        remove $a
        add address=$address list=$list comment=$comment disabled=$disabled
        }
        }
    ini tinggal di export saja address list nya

    tapi yang saya mau bukan seperti itu.
    akhirnya saya puter otak dan dapatkan script yang simpel dan sesuai dengan yang saya mau

    script nya seperti ini:
    Code:
    /ip firewall address-list
    print file=AddrVir where dynamic
    yang saya tebalkan adalah file nya.

    hasilnya kira2 seperti ini :
    Code:
    Flags: X - disabled, D - dynamic 
     #   LIST                                       ADDRESS                        
    21 D aaa IP Contain TCP Virus Port 8800         192.168.0.14                   
    22 D aaa Try To Internet                        192.168.0.252                  
    23 D aaa Try To Internet                        192.168.0.13

    Maap kl repost - cuma mau share aja
    Jgn di ejek / di ketawain ya
    masih nubi soal nya

    Click here to enlarge

    Mohon masukkan dari sesepuh di sini ..

  2. The Following User Says Thank You to oscark007 For This Useful Post:


 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Firewall - Address List
    By Dody in forum Beginner Basics
    Replies: 18
    Last Post: 21-08-2010, 17:03
  2. [ASK]spam terbaca pada address list
    By osadharmawan in forum General Networking
    Replies: 10
    Last Post: 15-08-2010, 13:19
  3. menampilkan address list tertentu
    By awarmanf in forum Scripting @ Mikrotik
    Replies: 0
    Last Post: 08-05-2010, 20:44
  4. Membuat List Mac address user
    By Howl in forum General Networking
    Replies: 2
    Last Post: 02-05-2008, 20:46
  5. address list
    By c0nf in forum General Networking
    Replies: 3
    Last Post: 06-11-2007, 17:50

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •