Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Results 1 to 14 of 14
  1. #1
    Status
    Offline
    alfondores's Avatar
    Baru Gabung
    Join Date
    Feb 2010
    Location
    http://klikalfon.info
    Posts
    10
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    kendala... Setting load balancing mikrotik + squid ubuntu server 9.10

    saya sudah berhasil setting load balancing 2 speedy saya. tapi muncul permasalahan ketika pelanggan bermain pokker. masalahnya pokker sering lag dan loading nya jadi lama. Saran teman coba pake external proxy.

    dengan bermodalkan pengetahuan seadaanya saya nekat setting sendiri squid ubuntu 9.10 dan tidak mengalami kendala.

    ketika saya coba menngkoneksikan mikrotik + squid malah tidak bisa browsing.
    tapi kalau saya hilang kan script ini pada Nat

    2 add chain=dstnat protocol=tcp dst-port=80 action=redirect to-ports=3128

    3 add chain=dstnat protocol=tcp dst-port=3128 action=redirect to-ports=3128

    4 add chain=dstnat protocol=tcp dst-port=8080 action=redirect to-ports=3128


    Browsing jadi normal kembali tapi main pokker facebook tetap bermasalah..

    Ada yang biisa bantu saya dimana salahnya mana tau nanti bisa jadi masukan buat teman nubie lainnya Maklum saya masih nubie yang nekat belajar sendiri. Click here to enlarge

    makasi banget sebelumnya Click here to enlarge

    Berikut script yang saya gunakan :

    Code:
    [xxxxx@MikroTik] > /ip address pr
    Flags: X - disabled, I - invalid, D - dynamic 
     #   ADDRESS            NETWORK         BROADCAST       INTERFACE
     0   192.168.0.50/24    192.168.0.0     192.168.0.255   lan      
     1   192.168.1.2/24     192.168.1.0     192.168.1.255   speedy1  
     2   192.168.2.2/24     192.168.2.0     192.168.2.255   speedy2  
     3   192.168.3.2/24     192.168.3.0     192.168.3.255   proxy
    Code:
    [xxxxx@MikroTik] ip firewall nat> pr
    Flags: X - disabled, I - invalid, D - dynamic 
     0   chain=srcnat out-interface=speedy1 action=masquerade 
    
     1   chain=srcnat out-interface=speedy2 action=masquerade 
    
    tambahan untuk pembelokan ke exsternal proxy..
     2   add chain=dstnat protocol=tcp dst-port=80 action=redirect to-ports=3128
    
     3   add chain=dstnat protocol=tcp dst-port=3128 action=redirect to-ports=3128
    
     4    add chain=dstnat protocol=tcp dst-port=8080 action=redirect to-ports=3128
    Code:
    [xxxxx@MikroTik] ip firewall mangle> pr
    Flags: X - disabled, I - invalid, D - dynamic 
     0   chain=prerouting in-interface=lan connection-state=new nth=1,1,0 action=mark-connection new-connection-mark=satu 
         passthrough=yes 
    
     1   chain=prerouting in-interface=lan connection-mark=satu action=mark-routing new-routing-mark=satu passthrough=no 
    
     2   chain=prerouting in-interface=lan connection-state=new nth=1,1,1 action=mark-connection new-connection-mark=dua 
         passthrough=yes 
    
     3   chain=prerouting in-interface=lan connection-mark=dua action=mark-routing new-routing-mark=dua passthrough=no 
    
     4   chain=prerouting in-interface=proxy connection-state=new nth=1,1,0 action=mark-connection new-connection-mark=tiga 
         passthrough=yes 
    
     5   chain=prerouting in-interface=proxy connection-mark=tiga action=mark-routing new-routing-mark=tiga passthrough=no 
    
     6   chain=prerouting in-interface=proxy connection-state=new nth=1,1,1 action=mark-connection new-connection-mark=empat 
         passthrough=yes 
    
     7   chain=prerouting in-interface=proxy connection-mark=empat action=mark-routing new-routing-mark=empat passthrough=no

    Code:
    [xxxxx@MikroTik] ip route> pr
    Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf 
     #     DST-ADDRESS        PREF-SRC        G GATEWAY         DISTANCE INTERFACE
     0 ADC 192.168.0.0/24     192.168.0.50                               lan      
     1 ADC 192.168.1.0/24     192.168.1.2                                speedy1  
     2 ADC 192.168.2.0/24     192.168.2.2                                speedy2  
     3 ADC 192.168.3.0/24     192.168.3.2                                proxy    
     4 A S 0.0.0.0/0                          r 192.168.1.1     1        speedy1  
     5 A S 0.0.0.0/0                          r 192.168.2.1     1        speedy2  
     6 A S 0.0.0.0/0                          r 192.168.1.1     1        speedy1  
     7   S 0.0.0.0/0                          r 192.168.2.1     2        speedy2

    Code:
    [xxxxx@MikroTik] > ip proxy pr
                        enabled: yes
                           port: 3128
                   parent-proxy: 192.168.3.1:3128
      maximal-client-connecions: 1000
      maximal-server-connectons: 1000
    
    [xxxxx@MikroTik] > ip web-proxy pr
                     enabled: yes
                 src-address: 0.0.0.0
                        port: 8080
                    hostname: "dewalinux"
           transparent-proxy: yes
                parent-proxy: 192.168.3.1:3128
         cache-xxxxxistrator: "alfondores@gmail.com"
             max-object-size: 4096KiB
                 cache-drive: system
              max-cache-size: unlimited
          max-ram-cache-size: unlimited
                      status: running
          reserved-for-cache: 411648KiB
      reserved-for-ram-cache: 2048KiB
    isi file squid.conf

    Code:
    http_port 192.168.3.1:3128 transparent
    visible_hostname dewalinux
    hierarchy_stoplist cgi-bin ?
    acl all src 0.0.0.0/0.0.0.0
    acl dewalinux src 192.168.0.0/255.255.255.0
    http_access allow dewalinux
    http_access allow all
    cache_dir ufs /usr/local/squid/cache 30000 16 256
    access_log /usr/local/squid/access.log
    cache_log /usr/local/squid/cache.log
    cache_store_log none
    cache_mem 1024 MB
    cache_swap_low 94
    cache_swap_high 96
    maximum_object_size 16384 KB
    minimum_object_size 4 KB
    maximum_object_size_in_memory 2048 KB
    fqdncache_size 1024
    acl QUERY urlpath_regex cgi-bin \?
    cache deny QUERY
    hosts_file /etc/hosts
    coredump_dir /var/spool/squid
    cache_mgr xxxxx@dewalinux
    cache_effective_user squid
    cache_effective_group squid
    
    cache_peer 192.168.3.1 parent 3128 3130
    ~

  2. #2
    Status
    Offline
    akbar_lana's Avatar
    VIP Member
    Join Date
    Aug 2007
    Location
    Jakarta, Indonesia, Indonesia
    Posts
    735
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    1 (100%)
    Click here to enlarge Originally Posted by alfondores Click here to enlarge
    Code:
    http_port 3128 transparent
    visible_hostname dewalinux
    hierarchy_stoplist cgi-bin ?
    acl all src 0.0.0.0/0.0.0.0
    acl dewalinux src 192.168.0.0/255.255.255.0
    http_access allow dewalinux
    http_access allow all
    cache_dir ufs /usr/local/squid/cache 30000 16 256
    access_log /usr/local/squid/access.log
    cache_log /usr/local/squid/cache.log
    cache_store_log none
    cache_mem 1024 MB
    cache_swap_low 94
    cache_swap_high 96
    maximum_object_size 16384 KB
    minimum_object_size 4 KB
    maximum_object_size_in_memory 2048 KB
    fqdncache_size 1024
    acl QUERY urlpath_regex cgi-bin \?
    cache deny QUERY
    hosts_file /etc/hosts
    coredump_dir /var/spool/squid
    cache_mgr xxxxx@dewalinux
    cache_effective_user squid
    cache_effective_group squid
    ~
    Coba konfig squid.conf di ubah seperti diatas, tapi alangkah baiknya jika tidak menggunakan parent proxy jadi langsung menggunakan dst-nat pada mikrotiknya, dan contoh nat nya seperti di bawah ini:

    Code:
    [xxxxx@MikroTik] ip firewall nat> pr
    Flags: X - disabled, I - invalid, D - dynamic 
     0   chain=srcnat out-interface=speedy1 action=masquerade 
    
     1   chain=srcnat out-interface=speedy2 action=masquerade 
    
    tambahan untuk pembelokan ke exsternal proxy..
     2   add chain=dstnat protocol=tcp dst-port=80 action=dst-nat to-addresses=192.168.3.1 to-ports=3128
    
     3   add chain=dstnat protocol=tcp dst-port=3128action=dst-nat to-addresses=192.168.3.1 to-ports=3128
    
     4    add chain=dstnat protocol=tcp dst-port=8080 action=dst-nat to-addresses=192.168.3.1 to-ports=3128

  3. The Following 3 Users Say Thank You to akbar_lana For This Useful Post:


  4. #3
    Status
    Offline
    putra_maiwa's Avatar
    Forum Guru
    Join Date
    Sep 2009
    Posts
    1,298
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by alfondores Click here to enlarge

    Code:
    [xxxxx@MikroTik] > ip proxy pr
                        enabled: yes
                           port: 3128
                   parent-proxy: 192.168.3.1:3128
      maximal-client-connecions: 1000
      maximal-server-connectons: 1000
    
    [xxxxx@MikroTik] > ip web-proxy pr
                     enabled: yes
                 src-address: 0.0.0.0
                        port: 8080
                    hostname: "dewalinux"
           transparent-proxy: yes
                parent-proxy: 192.168.3.1:3128
         cache-xxxxxistrator: "alfondores@gmail.com"
             max-object-size: 4096KiB
                 cache-drive: system
              max-cache-size: unlimited
          max-ram-cache-size: unlimited
                      status: running
          reserved-for-cache: 411648KiB
      reserved-for-ram-cache: 2048KiB
    memang gak bakalan bisa...
    klo pake proxy external, yg internal (bawaan MK) jgn d idupin..Click here to enlarge

  5. The Following 2 Users Say Thank You to putra_maiwa For This Useful Post:


  6. #4
    Status
    Offline
    teukurizal's Avatar
    Member
    Join Date
    Mar 2010
    Posts
    117
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    hmmm

    tunggu tutorial aq...loadbalansing + proxy ubuntu...makyuzzzzzClick here to enlarge

  7. The Following User Says Thank You to teukurizal For This Useful Post:


  8. #5
    Status
    Offline
    dionipe's Avatar
    Member Senior
    Join Date
    Dec 2009
    Location
    Malang, Indonesia
    Posts
    455
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    1
    Feedback Score
    0
    Hilangkan Routing Mark yang ada pada IP Route salah satu saja...
    dan juga hilangkan route yang mengarah ke proxy
    yang ini dihilangkan saja
    Code:
     3 ADC 192.168.3.0/24     192.168.3.2                                proxy  

  9. The Following User Says Thank You to dionipe For This Useful Post:


  10. #6
    Status
    Offline
    happiers07's Avatar
    Member
    Join Date
    Apr 2009
    Posts
    162
    Reviews
    Read 0 Reviews
    Downloads
    2
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by dionipe Click here to enlarge
    Hilangkan Routing Mark yang ada pada IP Route salah satu saja...
    dan juga hilangkan route yang mengarah ke proxy
    yang ini dihilangkan saja
    Code:
     3 ADC 192.168.3.0/24     192.168.3.2                                proxy  
    kok ga bisa di remove itu??
    couldn't remove........
    gtu broo tulisanya

  11. The Following User Says Thank You to happiers07 For This Useful Post:


  12. #7
    Status
    Offline
    cyber_byte's Avatar
    Baru Gabung
    Join Date
    Jul 2009
    Posts
    7
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    kok bisa gitu kenapa sih masgan ?Click here to enlarge

  13. #8
    Status
    Offline
    dherhu's Avatar
    Baru Gabung
    Join Date
    Jun 2011
    Posts
    4
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    ijin nyimak gan,, rencananya warnet ane jg mau pake squid...

    tp blm ngerti caranya Click here to enlarge

  14. #9
    Status
    Offline
    joen_spidy's Avatar
    Newbie
    Join Date
    May 2009
    Posts
    28
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    ikut menyimak aja gan, kali aja ada yg bisa di ambil Click here to enlarge

  15. #10
    Status
    Offline
    learn2live's Avatar
    Baru Gabung
    Join Date
    Jun 2011
    Posts
    11
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    i need to learn to balance 2 isp into one.

  16. #11
    Status
    Offline
    aris mdr's Avatar
    Baru Gabung
    Join Date
    Feb 2011
    Posts
    5
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    hohohoh.... nice gan .. ijin nyimak

  17. #12
    Status
    Offline
    m3tr0mini's Avatar
    Member Super Senior
    Join Date
    Sep 2007
    Posts
    660
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by learn2live Click here to enlarge
    i need to learn to balance 2 isp into one.
    whatlink do you use? adsl or wireless ??
    how is your network topology...??
    describe it here, and may be we can help you out.

    ---------- Post added at 01:40 ---------- Previous post was at 01:31 ----------

    Click here to enlarge Originally Posted by learn2live Click here to enlarge
    i need to learn to balance 2 isp into one.
    u can look at this link...
    Code:
    http://gregsowell.com/?p=2395
    may be it can help you out.

  18. #13
    Status
    Offline
    bangprans's Avatar
    Baru Gabung
    Join Date
    Jun 2011
    Posts
    7
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Ehm the good Tutorial

  19. #14
    Status
    Offline
    neostream's Avatar
    Baru Gabung
    Join Date
    Aug 2011
    Posts
    10
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by teukurizal Click here to enlarge
    tunggu tutorial aq...loadbalansing + proxy ubuntu...makyuzzzzzClick here to enlarge
    seepp gan.. Click here to enlargeClick here to enlarge

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [Tut]Load Balancing 2 Speedy + Squid (Ubuntu Server 9.10)+ Hotspot
    By dionipe in forum Beginner / Installation
    Replies: 120
    Last Post: 15-02-2013, 09:31
  2. load-balancing squid
    By felix_sg in forum General Networking
    Replies: 5
    Last Post: 25-04-2010, 20:30
  3. (ask) Load Balancing + Squid
    By cyberolog in forum General Networking
    Replies: 3
    Last Post: 20-10-2009, 21:54
  4. [ASK] Kenapa Squid Zph dan Load Balancing ?
    By manggatal in forum General Networking
    Replies: 3
    Last Post: 26-05-2009, 01:13

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •