Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Results 1 to 12 of 12
  1. #1
    Status
    Offline
    slamdunk2768's Avatar
    Newbie
    Join Date
    Feb 2010
    Posts
    41
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    Load Balance - PCQ

    Saya ada kesulitan utk load balance, saya menggunakan PCQ dengan pemikiran bisa menyesuaikan dgn user yang sedang online.
    Beberapa artike udah saya baca (termsuk dari sini dan wiki) tapi koq belum ada yang nyangkut.

    Konfigurasi

    PUBLIC (DHCP Client)
    |
    |---- local : 192.168.10.1/24 (utk diakses lewat wire)
    |
    |---- wlan : 192.168.20.1/24 (hotspot diakses wireless)

    Permasalahannya utl load balancing (LB) jika ada 2 user yg online beda segment misal :
    1. User A = 192.168.10.10
    2. User B = 192.168.20.15

    krn segment yang beda terebut yang kalau salah satu ada yang 'nyedot' pake IDM maka yang satunya bisa 'lelet' banget.
    Tapi jika yang online sama-sama di segment 192.168.10.0 maka bisa balance.

    Berikut beberapa settingan di MT saya:

    Flags: X - disabled, I - invalid, D - dynamic
    # ADDRESS NETWORK BROADCAST INTERFACE
    0 192.168.10.1/24 192.168.10.0 192.168.10.255 local
    1 192.168.20.1/24 192.168.20.0 192.168.20.255 wlan1

    [admin@MikroTik] /interface> pr
    Flags: D - dynamic, X - disabled, R - running, S - slave
    # NAME TYPE MTU L2MTU
    0 public ether 1500 1526
    1 local ether 1500 1522
    2 ether3 ether 1500 1522
    3 R wlan1 wlan 1500 2290

    [admin@MikroTik] /ip firewall> nat pr
    Flags: X - disabled, I - invalid, D - dynamic
    0 X ;;; place hotspot rules here
    chain=unused-hs-chain action=passthrough

    1 chain=srcnat action=masquerade out-interface=public

    2 chain=srcnat action=masquerade src-address=192.168.20.0/24
    out-interface=public

    3 chain=srcnat action=masquerade src-address=192.168.10.0/24
    out-interface=public


    [admin@MikroTik] /ip firewall> mangle pr
    Flags: X - disabled, I - invalid, D - dynamic
    0 chain=prerouting action=mark-packet new-packet-mark=upl-local-mark
    passthrough=no src-address=192.168.10.10 in-interface=local

    1 chain=forward action=mark-connection new-connection-mark=mark-conn-slm
    passthrough=yes src-address=192.168.10.10

    2 chain=prerouting action=mark-packet new-packet-mark=upl-local-mark
    passthrough=no src-address=192.168.10.11 in-interface=local

    3 chain=forward action=mark-connection new-connection-mark=mark-conn-slm
    passthrough=yes src-address=192.168.10.11

    12 chain=forward action=mark-packet new-packet-mark=dwn-local-mark
    passthrough=no in-interface=public connection-mark=mark-conn-slm

    13 chain=prerouting action=mark-packet new-packet-mark=upl-local-mark
    passthrough=no src-address=192.168.20.20 in-interface=wlan1

    14 chain=forward action=mark-connection new-connection-mark=mark-conn-slm
    passthrough=yes src-address=192.168.20.20

    15 chain=prerouting action=mark-packet new-packet-mark=upl-local-mark
    passthrough=no src-address=192.168.20.21 in-interface=wlan1

    16 chain=forward action=mark-connection new-connection-mark=mark-conn-slm
    passthrough=yes src-address=192.168.20.21

    [admin@MikroTik] /queue tree> pr
    Flags: X - disabled, I - invalid
    0 name="DWN" parent=local limit-at=0 priority=8 max-limit=0 burst-limit=0
    burst-threshold=0 burst-time=0s

    1 name="UPL" parent=global-in limit-at=0 priority=8 max-limit=0
    burst-limit=0 burst-threshold=0 burst-time=0s

    2 name="local-down" parent=DWN packet-mark=dwn-local-mark limit-at=0
    queue=auto-down priority=8 max-limit=1024k burst-limit=0
    burst-threshold=0 burst-time=0s

    3 name="local-up" parent=UPL packet-mark=upl-local-mark limit-at=0
    queue=auto-up priority=8 max-limit=256k burst-limit=0 burst-threshold=0
    burst-time=0s

    4 name="DWN-wlan" parent=wlan1 limit-at=0 priority=8 max-limit=0
    burst-limit=0 burst-threshold=0 burst-time=0s

    5 name="wlan-down" parent=DWN-wlan packet-mark=dwn-local-mark limit-at=0
    queue=default priority=8 max-limit=0 burst-limit=0 burst-threshold=0
    burst-time=0s

    [admin@MikroTik] /queue type> pr
    0 name="default" kind=pfifo pfifo-limit=50

    1 name="ethernet-default" kind=pfifo pfifo-limit=50

    2 name="wireless-default" kind=sfq sfq-perturb=5 sfq-allot=1514

    3 name="synchronous-default" kind=red red-limit=60 red-min-threshold=10
    red-max-threshold=50 red-burst=20 red-avg-packet=1000

    4 name="hotspot-default" kind=sfq sfq-perturb=5 sfq-allot=1514

    5 name="auto-down" kind=pcq pcq-rate=0 pcq-limit=50 pcq-classifier=dst-address
    pcq-total-limit=2000

    6 name="auto-up" kind=pcq pcq-rate=0 pcq-limit=50 pcq-classifier=src-address
    pcq-total-limit=2000

    7 name="default-small" kind=pfifo pfifo-limit=10


    Tolongnya masukannya,...udah 1 minggu nih tidur malem belum solve juga Click here to enlarge

    Thanks,
    slamdunk

  2. The Following 2 Users Say Thank You to slamdunk2768 For This Useful Post:


  3. #2
    Status
    Offline
    putra_maiwa's Avatar
    Forum Guru
    Join Date
    Sep 2009
    Posts
    1,298
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by slamdunk2768 Click here to enlarge
    Saya ada kesulitan utk load balance, saya menggunakan PCQ dengan pemikiran bisa menyesuaikan dgn user yang sedang online.
    Beberapa artike udah saya baca (termsuk dari sini dan wiki) tapi koq belum ada yang nyangkut.

    Konfigurasi

    PUBLIC (DHCP Client)
    |
    |---- local : 192.168.10.1/24 (utk diakses lewat wire)
    |
    |---- wlan : 192.168.20.1/24 (hotspot diakses wireless)

    Permasalahannya utl load balancing (LB) jika ada 2 user yg online beda segment misal :
    1. User A = 192.168.10.10
    2. User B = 192.168.20.15

    krn segment yang beda terebut yang kalau salah satu ada yang 'nyedot' pake IDM maka yang satunya bisa 'lelet' banget.
    Tapi jika yang online sama-sama di segment 192.168.10.0 maka bisa balance.

    Berikut beberapa settingan di MT saya:

    Flags: X - disabled, I - invalid, D - dynamic
    # ADDRESS NETWORK BROADCAST INTERFACE
    0 192.168.10.1/24 192.168.10.0 192.168.10.255 local
    1 192.168.20.1/24 192.168.20.0 192.168.20.255 wlan1

    [admin@MikroTik] /interface> pr
    Flags: D - dynamic, X - disabled, R - running, S - slave
    # NAME TYPE MTU L2MTU
    0 public ether 1500 1526
    1 local ether 1500 1522
    2 ether3 ether 1500 1522
    3 R wlan1 wlan 1500 2290

    [admin@MikroTik] /ip firewall> nat pr
    Flags: X - disabled, I - invalid, D - dynamic
    0 X ;;; place hotspot rules here
    chain=unused-hs-chain action=passthrough

    1 chain=srcnat action=masquerade out-interface=public

    2 chain=srcnat action=masquerade src-address=192.168.20.0/24
    out-interface=public

    3 chain=srcnat action=masquerade src-address=192.168.10.0/24
    out-interface=public


    [admin@MikroTik] /ip firewall> mangle pr
    Flags: X - disabled, I - invalid, D - dynamic
    0 chain=prerouting action=mark-packet new-packet-mark=upl-local-mark
    passthrough=no src-address=192.168.10.10 in-interface=local

    1 chain=forward action=mark-connection new-connection-mark=mark-conn-slm
    passthrough=yes src-address=192.168.10.10

    2 chain=prerouting action=mark-packet new-packet-mark=upl-local-mark
    passthrough=no src-address=192.168.10.11 in-interface=local

    3 chain=forward action=mark-connection new-connection-mark=mark-conn-slm
    passthrough=yes src-address=192.168.10.11

    12 chain=forward action=mark-packet new-packet-mark=dwn-local-mark
    passthrough=no in-interface=public connection-mark=mark-conn-slm

    13 chain=prerouting action=mark-packet new-packet-mark=upl-local-mark
    passthrough=no src-address=192.168.20.20 in-interface=wlan1

    14 chain=forward action=mark-connection new-connection-mark=mark-conn-slm
    passthrough=yes src-address=192.168.20.20

    15 chain=prerouting action=mark-packet new-packet-mark=upl-local-mark
    passthrough=no src-address=192.168.20.21 in-interface=wlan1

    16 chain=forward action=mark-connection new-connection-mark=mark-conn-slm
    passthrough=yes src-address=192.168.20.21

    [admin@MikroTik] /queue tree> pr
    Flags: X - disabled, I - invalid
    0 name="DWN" parent=local limit-at=0 priority=8 max-limit=0 burst-limit=0
    burst-threshold=0 burst-time=0s

    1 name="UPL" parent=global-in limit-at=0 priority=8 max-limit=0
    burst-limit=0 burst-threshold=0 burst-time=0s

    2 name="local-down" parent=DWN packet-mark=dwn-local-mark limit-at=0
    queue=auto-down priority=8 max-limit=1024k burst-limit=0
    burst-threshold=0 burst-time=0s

    3 name="local-up" parent=UPL packet-mark=upl-local-mark limit-at=0
    queue=auto-up priority=8 max-limit=256k burst-limit=0 burst-threshold=0
    burst-time=0s

    4 name="DWN-wlan" parent=wlan1 limit-at=0 priority=8 max-limit=0
    burst-limit=0 burst-threshold=0 burst-time=0s

    5 name="wlan-down" parent=DWN-wlan packet-mark=dwn-local-mark limit-at=0
    queue=default priority=8 max-limit=0 burst-limit=0 burst-threshold=0
    burst-time=0s

    [admin@MikroTik] /queue type> pr
    0 name="default" kind=pfifo pfifo-limit=50

    1 name="ethernet-default" kind=pfifo pfifo-limit=50

    2 name="wireless-default" kind=sfq sfq-perturb=5 sfq-allot=1514

    3 name="synchronous-default" kind=red red-limit=60 red-min-threshold=10
    red-max-threshold=50 red-burst=20 red-avg-packet=1000

    4 name="hotspot-default" kind=sfq sfq-perturb=5 sfq-allot=1514

    5 name="auto-down" kind=pcq pcq-rate=0 pcq-limit=50 pcq-classifier=dst-address
    pcq-total-limit=2000

    6 name="auto-up" kind=pcq pcq-rate=0 pcq-limit=50 pcq-classifier=src-address
    pcq-total-limit=2000

    7 name="default-small" kind=pfifo pfifo-limit=10


    Tolongnya masukannya,...udah 1 minggu nih tidur malem belum solve juga Click here to enlarge

    Thanks,
    slamdunk
    kenapa gak di buatkan BW Management, tergantung pake simple queue atau tree queue..

  4. #3
    Status
    Offline
    slamdunk2768's Avatar
    Newbie
    Join Date
    Feb 2010
    Posts
    41
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by putra_maiwa Click here to enlarge
    kenapa gak di buatkan BW Management, tergantung pake simple queue atau tree queue..
    Maksud pertanyaan saya diatas ya itu boss (sami mawon).

    Thanks,

  5. #4
    Status
    Offline
    putra_maiwa's Avatar
    Forum Guru
    Join Date
    Sep 2009
    Posts
    1,298
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by slamdunk2768 Click here to enlarge
    Maksud pertanyaan saya diatas ya itu boss (sami mawon).

    Thanks,
    masih kurang jelas neh...

    nanya nya Load balancing yg bermasalah..
    ato management BW nya....

    klo menurut ku di atas kamu pake tree queue ya...
    coba pake simple queue aja agar lbh muda..

  6. #5
    Status
    Offline
    adhielesmana's Avatar
    Administrator
    Join Date
    Jan 2009
    Location
    http://www.adhielesmana.com
    Posts
    3,054
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    setubuh sama putra maiwa.. klo susah2 pake pcq.. pake aja simple queue.. limit per PC beres.. atau pake konsep limit download unlimit browsing.. Click here to enlarge

  7. #6
    Status
    Offline
    slamdunk2768's Avatar
    Newbie
    Join Date
    Feb 2010
    Posts
    41
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by adhielesmana Click here to enlarge
    setubuh sama putra maiwa.. klo susah2 pake pcq.. pake aja simple queue.. limit per PC beres.. atau pake konsep limit download unlimit browsing.. Click here to enlarge
    Seprti di awal, nggak di limit,.....besarnya bandwith otomatis mengikuti user yang online. Jika yg online 1 user dapet full, tapi jika yg online 4 user maka setiap user otomatis masing-masing dapet 1/4 bandwith.

  8. #7
    Status
    Offline
    adhielesmana's Avatar
    Administrator
    Join Date
    Jan 2009
    Location
    http://www.adhielesmana.com
    Posts
    3,054
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by slamdunk2768 Click here to enlarge
    Seprti di awal, nggak di limit,.....besarnya bandwith otomatis mengikuti user yang online. Jika yg online 1 user dapet full, tapi jika yg online 4 user maka setiap user otomatis masing-masing dapet 1/4 bandwith.
    itu klo dipake secara normal.. klo dipake secara paksa alias IDM dan akslerator laiunnya.. ga bisa mas.. tetep tembus.. kecuali anda terapkan HTB.. baca aja di bagian artikel.. QOS & Traffic Shaping.. tentang pengaturan bandwith

  9. #8
    Status
    Offline
    slamdunk2768's Avatar
    Newbie
    Join Date
    Feb 2010
    Posts
    41
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by adhielesmana Click here to enlarge
    itu klo dipake secara normal.. klo dipake secara paksa alias IDM dan akslerator laiunnya.. ga bisa mas.. tetep tembus.. kecuali anda terapkan HTB.. baca aja di bagian artikel.. QOS & Traffic Shaping.. tentang pengaturan bandwith
    Maaf kalau saya salah nangkep, tadi awalnya saya pikir kalau menggunakan PCQ + Mangle bisa "otomatis balance". Hal ini didasari setelah saya baca artikel di kmd di dan di . Click here to enlarge

    Selain itu saya juga sudah coba test utk 1 segment yang sama memang berhasil (jika si A pake IDM maka si B tetap lancar browsing), saya mengalami problem jika si A pake IDM dan si B (beda segement dgn si A) maka si B akan lemot.

    thanks,Click here to enlarge
    Slamdunk

  10. #9
    Status
    Offline
    yogaponsel's Avatar
    Forum Guru
    Join Date
    Oct 2008
    Location
    "BnetAkses"
    Posts
    2,511
    Reviews
    Read 0 Reviews
    Downloads
    1
    Uploads
    0
    Feedback Score
    0
    kalo nat nya satu aja .... gimana gan dah di coba ..??
    1 chain=srcnat action=masquerade out-interface=public
    ------- yg in aja yg laen nggak usah pake ..??

  11. #10
    Status
    Offline
    slamdunk2768's Avatar
    Newbie
    Join Date
    Feb 2010
    Posts
    41
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by yogaponsel Click here to enlarge
    kalo nat nya satu aja .... gimana gan dah di coba ..??
    1 chain=srcnat action=masquerade out-interface=public
    ------- yg in aja yg laen nggak usah pake ..??
    Hmmmm,....bisa nggak ya nanti saya coba.Click here to enlarge

    thanks bro yogaponsel atas masukannya !Click here to enlarge

  12. #11
    Status
    Offline
    rio3834's Avatar
    Baru Gabung
    Join Date
    Oct 2009
    Posts
    2
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Bro slamdunk2768 udah berhasil blum?
    klo udah posting hasilnya dong...

    pernah ngalamin jg ky gini sih.. tp ga ktemu pemecahannya...

    barusan baru2 ini kepikiran mo di bridge aja... tp dah ga megang barangnya

  13. #12
    Status
    Offline
    loriyaga's Avatar
    Baru Gabung
    Join Date
    Jan 2008
    Posts
    13
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Load Balance PCC + BWM PCQ

    Speedy up to 1024kbps
    Biznet up to 2048kbps

    Lokal= 192.168.1.254 interface : Lokal5
    Wan1= 10.10.10.2 interface : speedy1
    wan2= 192.168.0.5 interface : biznet2

    PCC

    / ip address
    add address=192.168.1.254/24 network=192.168.1.0 broadcast=192.168.1.255 interface=Lokal5
    add address=10.10.10.2/24 network=10.10.10.0 broadcast=10.10.10.255 interface=speedy1
    add address=192.168.0.5/24 network=192.168.0.0 broadcast=192.168.0.255 interface=biznet2

    / ip firewall mangle
    add chain=prerouting dst-address=10.111.0.0/24 action=accept in-interface=Lokal5
    add chain=prerouting dst-address=10.112.0.0/24 action=accept in-interface=Lokal5
    add chain=prerouting in-interface=speedy1 connection-mark=no-mark action=mark-connection \
    new-connection-mark=speedy1_conn
    add chain=prerouting in-interface=biznet2 connection-mark=no-mark action=mark-connection \
    new-connection-mark=biznet2_conn
    add chain=prerouting in-interface=Lokal5 connection-mark=no-mark dst-address-type=!local \
    per-connection-classifier=both-addresses:2/0 action=mark-connection new-connection-mark=speedy1_conn
    add chain=prerouting in-interface=Lokal5 connection-mark=no-mark dst-address-type=!local \
    per-connection-classifier=both-addresses:2/1 action=mark-connection new-connection-mark=biznet2_conn
    add chain=prerouting connection-mark=speedy1_conn in-interface=Lokal5 action=mark-routing \
    new-routing-mark=to_speedy1
    add chain=prerouting connection-mark=biznet2_conn in-interface=Lokal5 action=mark-routing \
    new-routing-mark=to_biznet2
    add chain=output connection-mark=speedy1_conn action=mark-routing new-routing-mark=to_speedy1
    add chain=output connection-mark=biznet2_conn action=mark-routing new-routing-mark=to_biznet2

    / ip route
    add dst-address=0.0.0.0/0 gateway=10.10.10.1 routing-mark=to_speedy1 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=192.168.0.254 routing-mark=to_biznet2 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=10.10.10.1 distance=1 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=192.168.0.254 distance=2 check-gateway=ping

    / ip firewall nat
    add chain=srcnat out-interface=speedy1 action=masquerade
    add chain=srcnat out-interface=biznet2 action=masquerade

    PCQ


    /ip firewall mangle
    add action=mark-packet chain=prerouting new-packet-mark=upload passthrough=yes in-interface=Lokal5
    add action=mark-packet chain=postrouting new-packet-mark=download passthrough=no out-interface=Lokal5


    /queue type
    add kind=pcq name="bw_upload" pcq-classifier=src-address pcq-limit=15 pcq-rate=1536000 pcq-total-limit=500
    add kind=pcq name="bw_download" pcq-classifier=dst-address pcq-limit=15 pcq-rate=1536000 pcq-total-limit=500

    /queue tree
    add name="Bandwidth Management" parent=Lokal5 priority=3
    add max-limit=9216k name="client_up" packet-mark=upload parent="Bandwidth Management" priority=1 queue=bw_upload
    add max-limit=9216k name="Client_down" packet-mark=download parent="Bandwidth Management" priority=1 queue=bw_download

    mohon koreksinya dr para sesepuh dan suhu...........
    Last edited by loriyaga; 24-10-2011 at 14:12.

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. load balance + load balance
    By pc2console in forum Scripting @ Mikrotik
    Replies: 23
    Last Post: 24-06-2014, 17:12
  2. ask distance load balance
    By rie_y2k in forum General Networking
    Replies: 1
    Last Post: 13-07-2009, 14:17
  3. (Ask) Load Balance
    By iboyphinank in forum Beginner Basics
    Replies: 6
    Last Post: 03-01-2009, 18:51
  4. [Ask] 2 ISP no-load balance
    By Sumarjono in forum General Networking
    Replies: 11
    Last Post: 05-07-2008, 01:51
  5. help:load balance+speedy
    By ud1geol in forum Beginner Basics
    Replies: 5
    Last Post: 26-06-2008, 11:44

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •