Follow us on...
Follow us on G+ Follow us on Twitter Follow us on Facebook Watch us on YouTube
Register
Page 3 of 4 FirstFirst 1234 LastLast
Results 31 to 45 of 47
  1. Status
    Offline
    Calon Member Array
    Join Date
    Nov 2007
    Posts
    86
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0

    Jump to Comments

    NGE Limit Youtube Video Streaming di MT 3.xx

    46 Comments by maman Published on 21-04-2009 09:57
    To The Point saja

    Buat dulu http-video layer7-protocol nya

    Code:
    /ip firewall layer7-protocol
    add name=http-video regexp="http/(0\.9|1\.0|1\.1)[\x09-\x0d ][1-5][0-9][0-9][\x09-\x0d -~]*(content-type: video)"
    Mangle Mark Packet http-video nya

    Code:
    /ip frewall mangle
    add action=mark-packet chain=prerouting comment="http-video mark-packet" \
        disabled=no layer7-protocol=http-video new-packet-mark=http-video \
        passthrough=no
    Queue Simple http-video nya

    Code:
    /queue simple
    add max-limit=0/64000 name=http-video packet-marks=http-video
    Saat buka YouTube ..... kenceng, tapi saat Play Video langsung ke limit 64kbps

    Selamat mencoba

    | m | a | m | a | n |
    Last edited by maman; 29-04-2009 at 02:15.

  2. The Following 7 Users Say Thank You to maman For This Useful Post:


  3. Total Comments 46

    Comments

  4. #31
    Status
    Offline
    tyang_dusun's Avatar
    Member Super Senior
    Join Date
    Jun 2008
    Location
    Klaten, Jawa Tengah, Indonesia, Indonesia
    Posts
    521
    Reviews
    Read 0 Reviews
    Downloads
    1
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by banyak kasus Click here to enlarge
    coba yg ini :

    /ip firewall layer7-protocol
    http/(0\\.9|1\\.0|1\\.1)[\\x09-\\x0d ][1-5][0-9][0-9][\\x09-\\x0d -~]*(content-type: video)"


    menjadi :

    "http/(0\\.9|1\\.0|1\\.1)[\\x09-\\x0d ][1-5][0-9][0-9][\\x09-\\x0d -~]*(content-type: video/x-flv)"

    hanya penambahan : x-flv


    hanya saran lo ...kalau salah jangan diomelin ya ...

    ane coba dul y Gan .....

    ane kok heran it kok ada yg berhasil limit "8tube,p*rnhub,youp*rn,redtub, dan antek-anteknya"

    padahal regexnya sama persis ama punya ane, tpi kok punya cuma bisa ngelimit youtube dowank y ......... Click here to enlarge

  5. #32
    Status
    Offline
    jedan83's Avatar
    Calon Member
    Join Date
    Jul 2010
    Posts
    83
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    ip firewall layer 7 protocol
    add comment="" name="thunder-xvideos" \
    regexp="http:\\/\\/.*\\.xvideos\\.com.*\\.flv"

  6. The Following User Says Thank You to jedan83 For This Useful Post:


  7. #33
    Status
    Offline
    boejang's Avatar
    Newbie
    Join Date
    Jan 2011
    Posts
    34
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    parmios numpang ctrl+d

  8. #34
    Status
    Offline
    kweteng's Avatar
    VIP Member
    Join Date
    Nov 2009
    Location
    batu wae
    Posts
    797
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Code:
    ip fi m
    add action=mark-packet chain=postrouting comment="video" content=.flv disabled=no dst-address=192.168.88.0/24 \
        new-packet-mark=video-pkt out-interface=ether-Local passthrough=no
    add action=mark-packet chain=postrouting comment="video" content=.mpg disabled=no dst-address=192.168.88.0/24 \
        new-packet-mark=video-pkt out-interface=ether-Local passthrough=no
    add action=mark-packet chain=postrouting comment="video" content=.mp4
    disabled=no dst-address=192.168.88.0/24 \
        new-packet-mark=video-pkt out-interface=ether-Local passthrough=no
    
    
    dst ....
    dan limit idm/broser connection

    Code:
    /ip fi filter
    add action=accept chain=forward comment="block-idm-video" connection-limit=2,32 content=.flv  protocol=tcp
    baru masukan di quee tree
    Code:
    /queue tree
    add  max-limit=64k name=video packet-mark=video-pkt \
        parent=global-out priority=8 queue=default

    selain regex layer7/content bisa menggunakan squid (max conn dan delay pool)
    Code:
    acl locanet src 192.168.0.0/16
    acl max_idm maxconn 1
    cl file_video url_regex videoplayback
    http_access deny file_video max_idm localnet
    
    acl download url_regex -i \.(mpeg|mp4|flv|avi|mkv)
    
    delay_pools 1
    delay_class 1 2
    delay_parameters 1 10000/10000
    delay_access 1 allow download localnet
    delay_access 1 deny all
    delay_initial_bucket_level 100

    note: kalau di bawah ada router yang menggunakan masquarde lagi jangan gunakan maxcon baik di mikroitk/proxy

  9. The Following 4 Users Say Thank You to kweteng For This Useful Post:


  10. #35
    Status
    Offline
    lasak12's Avatar
    Baru Gabung
    Join Date
    Apr 2008
    Posts
    18
    Reviews
    Read 0 Reviews
    Downloads
    1
    Uploads
    0
    Feedback Score
    0
    Code:
    /ip firewall layer7-protocol
    add comment="" name=http-video regexp="http/(0\\.9|1\\.0|1\\.1)[\\x09-\\x0d ][\
    1-5][0-9][0-9][\\x09-\\x0d -~]*(content-type: video)"

    Code:
    /ip fi ma
    add action=mark-packet chain=prerouting comment="Mark Packet HTTP Video" \
    disabled=no in-interface=ether1 layer7-protocol=http-video \
    new-packet-mark=http-video-up passthrough=no
    add action=mark-connection chain=forward comment="" disabled=no \
    layer7-protocol=http-video new-connection-mark=video-stream passthrough=\
    yes
    add action=mark-packet chain=forward comment="" connection-mark=video-stream \
    disabled=no in-interface=ether2 layer7-protocol=http-video \
    new-packet-mark=http-video-down passthrough=no

    Code:
    /que typ
    add kind=pcq name=http-video-up pcq-classifier=src-address pcq-limit=50 \
    pcq-rate=0 pcq-total-limit=2000
    add kind=pcq name=http-video-down pcq-classifier=dst-address pcq-limit=50 \
    pcq-rate=0 pcq-total-limit=2000

    Code:
    /que sim
    add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" \
    direction=both disabled=no dst-address=0.0.0.0/0 interface=all limit-at=\
    64k/128k max-limit=64k/128k name="7. HTTP Video Traffict" packet-marks=\
    http-video-up,http-video-down parent=none priority=8 queue=\
    http-video-up/http-video-down total-queue=default-small
    add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" \
    direction=both disabled=no dst-address=0.0.0.0/0 interface=all limit-at=\
    0/0 max-limit=16k/96k name="Queue HTTP Video" packet-marks=\
    http-video-up,http-video-down parent="7. HTTP Video Traffict" priority=8 \
    queue=http-video-up/http-video-down target-addresses=0.0.0.0/0 \
    total-queue=default-small
    Untuk setingan diatas apa bisa pake que tree?

  11. #36
    Status
    Offline
    topkis's Avatar
    Baru Gabung
    Join Date
    Apr 2010
    Posts
    7
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by kweteng Click here to enlarge
    Code:
    ip fi m
    add action=mark-packet chain=postrouting comment="video" content=.flv disabled=no dst-address=192.168.88.0/24 \
        new-packet-mark=video-pkt out-interface=ether-Local passthrough=no
    add action=mark-packet chain=postrouting comment="video" content=.mpg disabled=no dst-address=192.168.88.0/24 \
        new-packet-mark=video-pkt out-interface=ether-Local passthrough=no
    add action=mark-packet chain=postrouting comment="video" content=.mp4
    disabled=no dst-address=192.168.88.0/24 \
        new-packet-mark=video-pkt out-interface=ether-Local passthrough=no
    
    
    dst ....
    dan limit idm/broser connection

    Code:
    /ip fi filter
    add action=accept chain=forward comment="block-idm-video" connection-limit=2,32 content=.flv  protocol=tcp
    baru masukan di quee tree
    Code:
    /queue tree
    add  max-limit=64k name=video packet-mark=video-pkt \
        parent=global-out priority=8 queue=default

    selain regex layer7/content bisa menggunakan squid (max conn dan delay pool)
    Code:
    acl locanet src 192.168.0.0/16
    acl max_idm maxconn 1
    cl file_video url_regex videoplayback
    http_access deny file_video max_idm localnet
    
    acl download url_regex -i \.(mpeg|mp4|flv|avi|mkv)
    
    delay_pools 1
    delay_class 1 2
    delay_parameters 1 10000/10000
    delay_access 1 allow download localnet
    delay_access 1 deny all
    delay_initial_bucket_level 100

    note: kalau di bawah ada router yang menggunakan masquarde lagi jangan gunakan maxcon baik di mikroitk/proxy
    maaf mau tanya om Click here to enlarge dst-address ini disesuaikan dengan ip kita ya

  12. #37
    Status
    Offline
    centurybos's Avatar
    Baru Gabung
    Join Date
    May 2011
    Posts
    3
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    matur nuwun, terima kasih para juragan semua yang telah ngetrit masalah ini.
    Click here to enlarge

  13. #38
    Status
    Offline
    topkis's Avatar
    Baru Gabung
    Join Date
    Apr 2010
    Posts
    7
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by hendrisiregar Click here to enlarge
    Ni bro buat batasi youtube serta files extention, coba aja telusuri disini

    Semoga berguna Click here to enlarge
    makasih banyak om Click here to enlarge
    ane cobain tutornya, maknyus banget Click here to enlarge

  14. The Following User Says Thank You to topkis For This Useful Post:


  15. #39
    Status
    Offline
    zole76's Avatar
    Newbie
    Join Date
    May 2010
    Posts
    25
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by dencow Click here to enlarge
    kalau ga jalan, mungkin proses penandaannya yang salah atau di queuenya ga sesuai atau di layer 7 nya yang kurang pas.

    kalau settingan test di routerku jalan aja kok, tapi aku pake pcq ya..
    cuman ya setingan seorang newbie yang ga pernah makan pojokan sekolah, kalau emang kurang pas tolong dikoreksi.
    nih aku exportin, ga nolak kalau di kasih ijo ijo Click here to enlarge

    oh ya, aku pake MT versi 3 yang udah aku upgrade ke 3.23 dua hari lalu Click here to enlarge


    Code:
    /ip firewall layer7-protocol
    add comment="" name=http-video regexp="http/(0\\.9|1\\.0|1\\.1)[\\x09-\\x0d ][\
        1-5][0-9][0-9][\\x09-\\x0d -~]*(content-type: video)"

    Code:
    /ip fi ma
    add action=mark-packet chain=prerouting comment="Mark Packet HTTP Video" \
        disabled=no in-interface=ether1 layer7-protocol=http-video \
        new-packet-mark=http-video-up passthrough=no
    add action=mark-connection chain=forward comment="" disabled=no \
        layer7-protocol=http-video new-connection-mark=video-stream passthrough=\
        yes
    add action=mark-packet chain=forward comment="" connection-mark=video-stream \
        disabled=no in-interface=ether2 layer7-protocol=http-video \
        new-packet-mark=http-video-down passthrough=no

    Code:
    /que typ
    add kind=pcq name=http-video-up pcq-classifier=src-address pcq-limit=50 \
        pcq-rate=0 pcq-total-limit=2000
    add kind=pcq name=http-video-down pcq-classifier=dst-address pcq-limit=50 \
        pcq-rate=0 pcq-total-limit=2000

    Code:
    /que sim
    add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" \
        direction=both disabled=no dst-address=0.0.0.0/0 interface=all limit-at=\
        64k/128k max-limit=64k/128k name="7. HTTP Video Traffict" packet-marks=\
        http-video-up,http-video-down parent=none priority=8 queue=\
        http-video-up/http-video-down total-queue=default-small
    add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="" \
        direction=both disabled=no dst-address=0.0.0.0/0 interface=all limit-at=\
        0/0 max-limit=16k/96k name="Queue HTTP Video" packet-marks=\
        http-video-up,http-video-down parent="7. HTTP Video Traffict" priority=8 \
        queue=http-video-up/http-video-down target-addresses=0.0.0.0/0 \
        total-queue=default-small

    tapi sepertinya urutan peletakan menentukan prestasi Click here to enlarge


    ket:
    ether1 interface ke klien
    ether2 interface ke ISP



    Click here to enlarge

    InGAT! JANGAN ASAL COPY PASTE. PELAJARI DULU LOGIKA DAN ALURNYA! Click here to enlarge

    Mau tanya kalau comment="" itu diisi dengan apa?

  16. #40
    Status
    Offline
    zole76's Avatar
    Newbie
    Join Date
    May 2010
    Posts
    25
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by topkis Click here to enlarge
    makasih banyak om Click here to enlarge
    ane cobain tutornya, maknyus banget Click here to enlarge

    Iya mantap gan tutorialnya...idm, you tube, xporn dll smuanya terlimit

  17. #41
    Status
    Offline
    mayonk's Avatar
    Baru Gabung
    Join Date
    Jun 2011
    Posts
    6
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    ikut nyimak ya kk...

  18. #42
    Status
    Offline
    otakjagung's Avatar
    Baru Gabung
    Join Date
    Jan 2011
    Posts
    5
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    sundul sundul

  19. #43
    Status
    Offline
    ulat_bulu's Avatar
    Baru Gabung
    Join Date
    Jul 2011
    Posts
    6
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    dicoba dulu yta

  20. #44
    Status
    Offline
    jtr678's Avatar
    Baru Gabung
    Join Date
    Jul 2011
    Posts
    3
    Reviews
    Read 0 Reviews
    Downloads
    0
    Uploads
    0
    Feedback Score
    0
    thx gan, buat pengetahuan... belon bisa praktekin, coz belon ada mikrotikx... Click here to enlarge

  21. #45
    Status
    Offline
    AaN_Deinstinct's Avatar
    Baru Gabung
    Join Date
    Aug 2010
    Location
    Jakarta
    Posts
    7
    Reviews
    Read 0 Reviews
    Downloads
    1
    Uploads
    0
    Feedback Score
    0
    Click here to enlarge Originally Posted by ripmanis Click here to enlarge
    masukinnya klo dari terminal gak mau yah !?!? Click here to enlarge
    tapi klo pake winbox kok mau Click here to enlarge
    jangan lupa pake tanda ( " ) kutip 2 gan...
    contoh = add comment="block facebook" name="facebook" regexp="facebook.com"Click here to enlarge

 

 
Page 3 of 4 FirstFirst 1234 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Articles

  1. [Video Tuts] Mensetting cache proxy MT biar tidak kena limit Queue
    By okto_2005 in forum QOS & Traffic Shaping
    Replies: 57
    Last Post: 03-03-2015, 15:58
  2. Limit YouTube
    By sone in forum General Networking
    Replies: 41
    Last Post: 20-10-2013, 17:49
  3. Tanya:Gmn caranya ngeBlok Video Streaming?
    By chenia in forum General Networking
    Replies: 11
    Last Post: 12-07-2011, 13:47
  4. [Help] Limit youtube
    By nipluk in forum General Networking
    Replies: 1
    Last Post: 08-02-2008, 16:40

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •